Полезные приемы при работе с Excel из 1С (Версия 3.1)

Публикация № 398279

Разработка - Практика программирования

Excel работа с

Программисту 1С часто приходится работать с таблицами Excel из 1С. Я постарался собрать небольшой FAQ и набор функций для работы с файлами Excel. Надеюсь, кому-то будет полезна данная статья.

Работать с файлами Excel можно тремя способами:

  1. Через OLE  объект;
  2. Через Табличный Документ 1С.
  3. Через ADODB

Разберем первый способ.

1. Подключаемся к  OLE и октрываем файл  Excel:

//Поключимся к Excel через OLE, откроем файл и вернем список страниц
	//ИмяФайла = Полный путь к файлу Excel
	Соотв = Новый Соответствие;
	Попытка 
		Листы = Новый Массив;
		Excel = Новый COMОбъект("Excel.Application");
		Соотв.Вставить("Соединение",Excel);
	    ExcelФайл = Excel.WorkBooks.Open (ИмяФайла);
		Соотв.Вставить("ExcelФайл",ExcelФайл);
		Для Сч = 1 По ExcelФайл.Sheets.Count Цикл
			Листы.Добавить(ExcelФайл.Sheets(Сч));
		КонецЦикла;
		Соотв.Вставить("Листы",Листы);
		лРезультат = Соотв;
	Исключение
		Сообщить("Ошибка создания обьекта Microsoft Excel" + ОписаниеОшибки());
		лРезультат = Неопределено;
	КонецПопытки;
	
	Возврат лРезультат;

 

Отсоединяемся от Excel и закрываем файл:

После манипуляции с файлом необходимо его закрыть. В противном случае он останется захваченным в системе, и мы не сможем его использовать в других приложениях.

Процедура  ОтключатьсяОтExcel(Соответстие)
	Попытка
		Соответстие["Соединение"].DisplayAlerts = 0;
		Соответстие["ExcelФайл"].Close();
		Соответстие["Соединение"].DisplayAlerts = 1;
		Соответстие["Соединение"].Quit(); 
		Соответстие["Соединение"] = Неопределено;		
	Исключение
		Сообщить("Не удалось отключиться от Excel - "+ОписаниеОшибки());
	КонецПопытки;
КонецПроцедуры

Клиент-Серверный вариант в управляемых формах.

При работе в клиент-серверном варианте основная трудность заключается в том, что обычно файл мы загружаем на стороне клиента, а данные, как правило, обрабатываем на стороне сервера. Причем, таблицу значений нельзя передать от клиента на сервер (точнее, передать таблицу значений можно, но только в толстом клиенте. На тонком - 1С выдаст вам сообщение об ошибке). Есть два пути решения данной задачи:

1. Считываем данные из файла в массив из структур и затем этот массив передаем на сервер для дальнейших манипуляций с данными.

&НаКлиенте
Процедура Загрузить1(Команда)
	Если Объект.ИмяФайла = "" Тогда
		Сообщение = Новый СообщениеПользователю;
		Сообщение.Текст = "Не указан файл для загрузки";
		Сообщение.Поле = "Объект.ИмяФайла";
		Сообщение.Сообщить();
		Возврат;
	КонецЕсли;
	
	Соединение = ПоключитьсяКExcel(Объект.ИмяФайла);
	Если Соединение = Неопределено Тогда
		Возврат;
	КонецЕсли;
	
	Лист = Соединение["Листы"][0];
	//Создаем Массив для строк
	МассивДанных = Новый Массив;
		
	ВсегоКолонок = Лист.Cells(1,1).SpecialCells(11).Column;
	ВсегоСтрок = Лист.Cells(1,1).SpecialCells(11).Row;
	
	Для Сч = 1 по ВсегоСтрок Цикл
		
		//Создаем структуру для текущей строки
		Строка = Новый Структура;
		Для Сч2 = 1 по ВсегоКолонок Цикл
			 Строка.Вставить("Колонка"+Строка(Сч2),Лист.Cells(Сч,Сч2).Value);
		КонецЦикла;
		
		МассивДанных.Добавить(Строка);
	КонецЦикла;
	
	Загрузить1НаСервере(МассивДанных);
КонецПроцедуры

&НаСервере
Процедура Загрузить1НаСервере(МассивДанных)
	//Создадим колонки
	Если МассивДанных.Количество() = 0 Тогда
		Возврат;
	КонецЕсли;
	
	Таб = РеквизитФормыВЗначение("Результат");
	
	МассивРеквизитов = Новый Массив;	
	
	Для Каждого Кл Из МассивДанных[0] Цикл
		Мас = Новый Массив;
		Мас.Добавить(ТипЗнч(Кл.Значение));
		
		Таб.Колонки.Добавить(Кл.Ключ,Новый ОписаниеТипов(Мас),Кл.Значение);
	КонецЦикла;
	
	Первая = Истина;
	Для Каждого Ст ИЗ МассивДанных Цикл
		Если Первая Тогда
			Первая = Ложь;
			Продолжить;
		КонецЕсли;
		ТБ = Таб.Добавить();
		Для Каждого Кл из СТ Цикл
			ТБ[Кл.Ключ] = Кл.Значение;
		КонецЦикла;
		
	КонецЦикла;
	
	ОтобразитьТабНаФорме(Таб);
	
КонецПроцедуры

2-ой способ - это передать файл Excel на сервер через хранилище данных и далее работать с ним уже на сервере.

&НаСервере
Процедура Загрузить2НаСервере(пФайл)
	лФайл = ПолучитьИмяВременногоФайла("xlsx");
	лДвоичДанные = ПолучитьИзВременногоХранилища(пФайл);
	лДвоичДанные.Записать(лФайл);
	
	Соединение = ПоключитьсяКExcelСервер(Объект.ИмяФайла);
	Если Соединение = Неопределено Тогда
		Возврат;
	КонецЕсли;
	/// Обработка Excel
	ОтключатьсяОтExcelСервер(Соединение);	
КонецПроцедуры

&НаКлиенте
Процедура Загрузить2(Команда)
	лДвоичДанные = Новый ДвоичныеДанные(Объект.ИмяФайла);
	лФайл = ПоместитьВоВременноеХранилище(лДвоичДанные);	
	Загрузить2НаСервере(лФайл);
КонецПроцедуры

Очень часто приходится работать с очень большими  файлами Excel, и его обработка путем перебора строк занимает огромное количество времени. 

В таких случаех удобно в одно действие загрузить всю таблицу в массив и в потом работать уже непосредственно с  массивом.

Лист = Соединение["Листы"][0];
	
	ВсегоКолонок = Лист.Cells(1,1).SpecialCells(11).Column;
	ВсегоСтрок = Лист.Cells(1,1).SpecialCells(11).Row;

	Область = Лист.Range(ЛистЭксель.Cells(1,1), ЛистЭксель.Cells(ВсегоСтрок,ВсегоКолонок));
	Данные = Область.Value.Выгрузить();

На выходе получаем двумерный массив, который содержит все данные указанного листа Excel

Полезные функции при работе с Excel:

 Устанавливает видимость Excel при работе
//0 - Excel не виден, 1 - виден.
 Соединение.Visible = Видимость;
 Добавление новой книги в файл Excel
Книга = Соединение.WorkBooks.Add();
 Сохранение книги Excel
Книга.SaveAs(ИмяФайла);
 Добавление нового листа к книге
Лист = Книга.WorkSheets.Add();
 Переименование листа
Лист.Name = ИмяЛиста;
 Изменение маштаба листа
//"Масштаб" (от 10 до 400).
Лист.PageSetup.Zoom = Масштаб;
 Изменение ориентации листа
//1 - книжная, 2 - альбомная.
Лист.PageSetup.Orientation = Ориентация;
 Отступы листа
//Левый отступ
Лист.PageSetup.LeftMargin = Соединение.CentimetersToPoints(Сантиметры);
//Верхний отступ
Лист.PageSetup.TopMargin = Соединение.CentimetersToPoints(Сантиметры);
//Правый отступ
Лист.PageSetup.RightMargin = Соединение.CentimetersToPoints(Сантиметры);
//Нижний отступ
Лист.PageSetup.BottomMargin = Соединение.CentimetersToPoints(Сантиметры);
Обращение к ячейки
чтение/запись 
//Прочитать значение ячейки
//Сч = Номер строки
//Сч2 = Номер колонки
Данные = Лист.Cells(Сч,Сч2).Value

//Записать значение в ячейку
Лист.Cells(Сч,Сч2).Value =  Данные
Обращение к области ячеек
//В качестве параметров передаем ячейки по диогонали
Лист.Range(ЛистЭксель.Cells(1,1),ЛистЭксель.Cells(ВсегоСтрок,ВсегоКолонок))
Очень часто при чтении или записи значений в Excel ставятся лишние пробелы в числе, например, вместо 1502 он читает как 1 502 и в дальнейшем это значение не приводится к числу. Эту проблему можно решить заменой.
ЗначениеЯчейки = Лист.Cells(1,3).Value;
СтрЗаменить(Строка(ЗначениеЯчейки),Символы.НПП,"");
Объединение ячеек
Лист.Range(Лист.Cells(1,1),Лист.Cells(10,1)).Merge();	

 
Работа с именованными ячейками в Excel
Обл = Лист.Range("Имя_Ячейки_В_Excel").Select();	
Обл.Value = "Присваиваем значение";

 
Удаление ячейки 
Лист.Cells(1,3).Delete();
Удаление области ячеек
Лист.Range(Лист.Cells(1,1),Лист.Cells(10,1)).Delete();
 Обращение к строке
//Сч = Номер строки
Лист.Rows(Сч)
 Изменение ширины колонки
Лист.Columns(НомерКолонки).ColumnWidth = Ширина;
 Обращение к колонке
//Сч = Номер Колонки
Лист.Cols(Сч)
 Удаление Строки
Лист.Rows(Сч).Delete()
 Фон ячейки / области / Строки /  
//Фон Ячейки
Лист.Cells(1,1).Interior.Color = ПолучитьЦветExcelRGB(10,10,10);

//Фон Области
Лист.Range(Лист.Cells(1,1),Лист.Cells(10,1)).Interior.Color = ПолучитьЦветExcelRGB(10,10,10);

//Фон строки
Лист.Rows(Сч).Interior.Color = ПолучитьЦветExcelRGB(10,10,10);

 
 Функция переводит цвет из формата RGB в формат Excel
Функция ПолучитьЦветExcelRGB(R,G,B)
	Возврат ((B*256) + G) * 256 + R;
КонецФункции
 Управление шрифтом в ячейки/строке/области
//Изменение шрифта
Лист.Cells(НомерСтроки,НомерКолонки).Font.Name = ИмяШрифта;

//Изменение размера шрифтв
Лист.Cells(НомерСтроки,НомерКолонки).Font.Size = РазмерШрифта;

//Управление жирностью шрифта
//1-жирный шрифт (bold)
//0-нормальный шрифт (normal)
Лист.Cells(НомерСтроки,НомерКолонки).Font.Bold = Жирный;

//Управление курсивом шрифта
//1-Курсив
//0-Нормальный
Лист.Cells(НомерСтроки,НомерКолонки).Font.Italic = Курсив;

//2 - Подчеркнутый шрифт
//1- нет
Лист.Cells(НомерСтроки,НомерКолонки).Font.Underline = Подчеркнутый;
 Разрешает переносить по словам в ячейке
//1-Переносить
Лист.Cells(1, 1).WrapText = 1;
 Управление рамкой ячейки
//1 - Тонкая сплошная линия
Лист.Cells(НомерСтроки,НомерКолонки).Borders.Linestyle = ТипЛинии;
 Устанавливаем формат ячейки
//"@" - текстовый
//"0.00" - числовой
Лист.Cells(НомерСтроки, НомерКолонки).NumberFormat = Формат;
 Формула в ячейки 
Лист.Cells(Сч,Сч2).FormulaLocal = "=ОКРУГЛ(135,46456;0)";
 Формула в ячейки 
Лист.Cells(Сч,Сч2).FormulaLocal = "=ОКРУГЛ(135,46456;0)";
 Формула в ячейки 
Лист.Cells(Сч,Сч2).FormulaLocal = "=ОКРУГЛ(135,46456;0)";
 Формула в ячейки 
Лист.Cells(Сч,Сч2).FormulaLocal = "=ОКРУГЛ(135,46456;0)";
 Функция для получения ширины колонки Excel 
Спасибо пользователю goodwill
&НаКлиенте
Функция ПолучитьШиринуКолнкиЭксель(ПараметрШиринаВПикселях)
    
    Если ПараметрШиринаВПикселях > 9 Тогда 
        ШиринаВСимволах = (ПараметрШиринаВПикселях/0.75-5)/7;
    Иначе
        ШиринаВСимволах = ПараметрШиринаВПикселях/9;
    КонецЕсли;

    Возврат ШиринаВСимволах;
    
КонецФункции

Лист.Columns("A").ColumnWidth = ПолучитьШиринуКолнкиЭксель(РазмерШиринаВПикселях);
 Разрешить перенос слов в ячейке  
Спасибо пользователю roofless
Лист.Cells(1, 1).WrapText = 1;
 Группировки данных на листе  
Спасибо пользователю dr-wit, ignor
1. Развернуть все группы (строки и колонки):
Excel.ActiveSheet.Outline.ShowLevels(3, 3);
2. Сернуть все группы (строки и колонки) до первого уровня:
Excel.ActiveSheet.Outline.ShowLevels(1, 1); 
3. Вернуть глубину дерева
Лист.Rows(Инд).OutlineLevel 

 

При работе с Excel мы оперируем столбцами как числом (Например, 1 столбец), а у Excel адресация столбцов производится с помощью символов. И когда нам нужно отредактировать формулу, то нам нужно номер столбца преобразовать в символ. В таких случаях вам пригодится эта функция.

Функция ПреобразоватьНомерСтолбцаВФорматExcel(Столбец)
	стСтолбец = "";
	А = Окр(Столбец/27,0);
	В = Столбец - (А*26);
	Если А>0 Тогда
		стСтолбец = Символ(А+64);
	КонецЕсли;
	Если В>0 Тогда
		стСтолбец = стСтолбец + Символ(В+64);
	КонецЕсли;
	
	Возврат стСтолбец;
КонецФункции

2. Работа с Excel через ТабличныйДокумент 1С

С помощью данного метода можно и загружать из Excel и выгружать в Excel. Но на мой взгляд этот метод идепально подходит когда вам необходимо посто сохранить информацию в Excel без дальнейшей манипуляции.

Итак, приступим: загрузка из Excel:

1. Загружаем файл Excel в табличный документ

//Файл - это файл Excel
	ТабДок = Новый ТабличныйДокумент;
	Попытка
		ТабДок.Прочитать(Файл, СпособЧтенияЗначенийТабличногоДокумента.Значение);
	Исключение
		Сообщение = Новый СообщениеПользователю;
		Сообщение.Текст = ОписаниеОшибки();
		Сообщение.Сообщить();
		Возврат Неопределено;
	КонецПопытки;

 2. Производим манипуляции уже с ТабличнымДокументом

//Создадим ТЗ куда будем собирать инфу
	Таб = Новый ТаблицаЗначений;
	Таб.Колонки.Добавить("Номенклатура",Новый ОписаниеТипов("Строка"));
	Таб.Колонки.Добавить("Количество",Новый ОписаниеТипов("Число"));
	Таб.Колонки.Добавить("Цена",Новый ОписаниеТипов("Число"));
	
//Определяем количество строк
	КолСтр = ТабДок.ВысотаТаблицы;
	Для Сч = 2 по КолСтр Цикл
		Попытка
			ТБ = Таб.Добавить();
//Обращаемся к ячейки и забираем данные
			ТБ.Номенклатура = Строка(ТабДок.ПолучитьОбласть("R" + Формат(Сч, "ЧГ=0") + "C" + 1).ТекущаяОбласть.Текст);		
			ТБ.Количество = Число(ТабДок.ПолучитьОбласть("R" + Формат(Сч, "ЧГ=0") + "C" + 2).ТекущаяОбласть.Текст);				
			ТБ.Цена = Число(ТабДок.ПолучитьОбласть("R" + Формат(Сч, "ЧГ=0") + "C" + 3).ТекущаяОбласть.Текст);		
		Исключение
			Сообщение = Новый СообщениеПользователю;
			Сообщение.Текст = "Не удалось загрузить строку "+Строка(Сч);
			Сообщение.Сообщить();
		КонецПопытки;
	КонецЦикла;

Давайте теперь разберем сохранение в Excel с помощью данного метода:

Тут все очень просто сначала мы формируем обычный Табличный документ и затем записываем его в Excel

//ТабДок - Табличный документ
	ТабДок.Записать(Объект.ИмяФайла,ТипФайлаТабличногоДокумента.XLSX);

2. Работа с Excel ADODB

Выражаю особую благодарность коллеги Fragster за хороший комментарий

Данный метод позволяет работать с Excel через ODBC и имеет ряд преимуществ:

  1. Не требует установки самой Excel, необходима лишь установить ODBC.  Но как правило  он уже установлен. Это особенность позволяет работать на стороне сервера без дополнительных установок Excel.
  2. Позволяет работать с таблицой Excel как с БД и строить к ней запросы на T-SQL. Таким образом мы можем делать отборы еще на этапе чтения данных и другие преимущества что дает  Т-SQL. Что на мой взгляд огромный плюс.

Подключение к ADO

Функция СоединитьсяСADO(ИмяФайла)
	//Поз = СтрНайти(ИмяФайла,"\",НаправлениеПоиска.СКонца);
	Поз = 0;
	Найден = 1;
	ТмпСтр = ИмяФайла;
	Пока Найден <> 0 Цикл
		Найден = Найти(ТмпСтр,"\");
		ТмпСтр = Прав(ТмпСтр,СтрДлина(ТмпСтр) - Найден);
		Если Найден <> 0 Тогда
			Поз = Найден;
		КонецЕсли;
	КонецЦикла;
	Путь = Лев(ИмяФайла,Поз-1);                 	
	
	Данные = Новый Структура;
	СтрокаСоединения = "
	| Provider=Microsoft.ACE.OLEDB.12.0;Data Source="+СокрЛП(ИмяФайла)+";
	| Extended Properties=""Excel 12.0 Xml;HDR=YES""";
	Соединение = Новый COMОбъект("ADODB.Connection");	
	Попытка		
		Соединение.Open(СтрокаСоединения);           		
	Исключение		
		Сообщить ("Не возможно подключится к Microsoft Excel Driver!!!		
		|Возможно файл ["+ИмяФайла+"] открыт другим пользователем.");		
		Возврат Неопределено;
	КонецПопытки;
	Данные.Вставить("Соединение",Соединение);
		
	Возврат Данные;
КонецФункции

Строка подключения зависит от версии ODBC. И вызывает наибольшие трудности при подключение поэтомя я рекомендую ее сгенерировать на сайте http://www.connectionstrings.com

Отключение от ADO

Процедура ОтключитьсяОтADO(Подключение)
	Попытка
		Подключение["Соединение"].Close();
		Подключение = Неопределено;
	Исключение
	КонецПопытки;
КонецПроцедуры


Выполнение запроса

Функция ВыполнитьЗапросADO(ТекстЗапроса,Подключение)
	Попытка		
		Записи = Новый COMОбъект("ADODB.Recordset");           		
	Исключение		
		Сообщить ("Не удалось Создать к Microsoft Excel Driver!!!");		
		Возврат Неопределено;
	КонецПопытки;
    Попытка
        Записи.Open(ТекстЗапроса, Подключение["Соединение"]);
		Возврат Записи;
	Исключение
	    Сообщить ("Проблемы с выполнением запроса");
	КонецПопытки;	
КонецФункции

Пример запроса:

//Сразу отбираем только не пустые номенклатуры
ТекстЗапроса = "SELECT * FROM [Лист1$] WHERE `Номенклатура`<>""""";

Запись в  Excel тоже производится в виде запроса:

ТекстЗапроса = "    
		|INSERT INTO [Лист1$] (`Номенклатура`,`Количество`,`Цена`,`Сумма`) VALUES ('"
	+ТБ.Номенклатура+"','"+ТБ.Количество+"','"+ТБ.Цена+"','"+ТБ.Сумма+"')";

Хочу отметить что наименование полей производится по первой строке в таблице

 

ADODB предоставляет ряд объектов, с которыми мы работаем

ADODB.Connection
предназначен для соединения с ADO
Соединение = Новый COMОбъект("ADODB.Connection");

 

  ADOX.Table
для работы с таблицей
// Создаем таблицу и добавляем в неё два столбца
Table = Новый COMОбъект("ADOX.Table");
Table.Name = "Table";
Table.Columns.Append("Code");
Table.Columns.Append("Description");

 

ADODB.Command Для выполнения комманд на языке T-SQL
Комманды = Новый COMОбъект("ADODB.Command");
	Комманды.ActiveConnection = Подключение["Соединение"];
	Комманды.CommandType = 1;
	Комманды.CommandText = ТекстЗапроса;
	Комманды.Execute();

 

 ADODB.Recordset

Похож на ADODB.Command предназначен для выполнения запросов и обработки результата 

Записи = Новый COMОбъект("ADODB.Recordset"); 
Записи.Open(ТекстЗапроса, Подключение["Соединение"]);

 

 

В файле продемонстрированны оба варианта работы с запросами.

 

На этом пока все. По возможности буду дополнять статью :)

 

В архиве находится обработка, которая демонстрирует все описанные и другие возможности при работе с Excel.

И тренировочный файл Excel.

Скачать файлы

Наименование Файл Версия Размер
РаботаСExcel(Управляемые формы).zip

.zip 14,28Kb
23.03.17
221
.zip 14,28Kb 221 Скачать
Демонстрация работы с Excel через ADODB

.zip 13,44Kb
23.03.17
125
.zip 13,44Kb 125 Скачать
Демонстрация работы с Excel через Табличный документ 1С (УФ)

.zip 13,87Kb
23.03.17
135
.zip 13,87Kb 135 Скачать

Специальные предложения

Вознаграждение за ответ
Показать полностью
Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. Krasnyj 1263 23.09.15 09:13 Сейчас в теме
Дельная подборка. Полезная. Спасибо.
Gendelf; Spakus; Мах; sergio199; +4 Ответить
2. Fragster 1019 23.09.15 10:24 Сейчас в теме
Забыто про UsedRange, а также про то, что передача через ComSafeArray работает в обе стороны.
SCHNEIDER GROUP; spogo; kovgard; psih12; +4 Ответить
3. Fragster 1019 23.09.15 10:32 Сейчас в теме
Ну и про вариант через ADO с плюшками SQL запросов типа фильтрации, группировок и джоинов данных с разных листов
_also; Zerocl; Йожкин Кот; +3 Ответить
9. Zerocl 576 30.09.15 10:05 Сейчас в теме
(3) Fragster, Добавил небольшое описание ADO
Fragster; +1 Ответить
4. Zerocl 576 23.09.15 11:58 Сейчас в теме
Спасибо за очень полезные комментарии. В ближайшее время добавлю по работе с Excel через Табличный документ и потом постараюсь осветить ваши темы.
5. roofless 22 23.09.15 15:48 Сейчас в теме
отлично, добавьте
Лист.Cells(1, 1).WrapText = 1;

разрешает переносить по словам в ячейке
arakelyan; +1 Ответить
6. Zerocl 576 23.09.15 16:52 Сейчас в теме
(5) roofless, Спасибо большое! Добавил
7. spy-83 187 24.09.15 06:10 Сейчас в теме
помоему конструкция
Excel = Новый COMОбъект("Excel.Application");

на сервере не взлетит. не?
8. roofless 22 24.09.15 07:51 Сейчас в теме
(7) spy-83, если апликейшен будет на сервере, то взлетит
24. spy-83 187 15.03.16 10:40 Сейчас в теме
(8) roofless, а если сервер на линуксе?
27. Zerocl 576 16.03.16 20:18 Сейчас в теме
(24) spy-83, На линуксе я не пробовал, но он там где то же временные файлы хранит
57. dobrynin.i.s 93 05.04.19 07:41 Сейчас в теме
(24) на линуксе не взлетит , так как нет ком объектов там
10. malets 2 30.09.15 12:07 Сейчас в теме
Спасибо большое, очень полезная статья!
11. volit 01.10.15 13:57 Сейчас в теме
Спасибо все очень понятно и подробно!
62. kotov2000 5 25.11.19 09:13 Сейчас в теме
Коллеги, подскажите.
Раз есть команда Область.Value.Выгрузить(), то, наверное, есть что-то наподобие загрузить в лист Excel?

Очень часто приходится работать с очень большими файлами Excel, и его обработка путем перебора строк занимает огромное количество времени.

В таких случаех удобно в одно действие загрузить всю таблицу в массив и в потом работать уже непосредственно с массивом.

Лист = Соединение["Листы"][0];

ВсегоКолонок = Лист.Cells(1,1).SpecialCells(11).Column;
ВсегоСтрок = Лист.Cells(1,1).SpecialCells(11).Row;

Область = Лист.Range(ЛистЭксель.Cells(1,1), ЛистЭксель.Cells(ВсегоСтрок,ВсегоКолонок));
Данные = Область.Value.Выгрузить();
12. rasswet 82 01.10.15 14:58 Сейчас в теме
опыта работы с именованными ячейками у вас нет?
если есть может есть смысл добавить сюда в статью?
13. Zerocl 576 01.10.15 15:13 Сейчас в теме
(12) rasswet, Добавил. Смотрите табличку
14. Shokei 19.11.15 13:25 Сейчас в теме
Спасибо автору ,попробуем
15. skif47 328 19.11.15 13:40 Сейчас в теме
Плюсую, для больших файлов ADO дает просто огромную скорость обработки, только им и пользуюсь.
16. dwarkin 05.02.16 14:47 Сейчас в теме
Очень хорошая статья, сильно помогла, особенно ссылка на connectionstrings.com. Спасибо большое.
Для ADO, если система 64 бит, а 1Ска - 32, то надо ставить Microsoft Access Database Engine 2010 Redistributable (16/12/2010) 32 и 64 - разрядные версии.
В моем случае помогла 32бит версия (система 64бит (Вин 7, Вин2008Ент), 1Ска - 32 бит).
На Вин7 стоял Офис 2010, но видать какой-то резанный. Все равно пришлось так же ставить Access Database Engine 32 бит.
17. tormozit 5962 06.02.16 15:20 Сейчас в теме
Для редактирования и отладки запросов к ADO можно использовать консоль запросов из подсистемы Инструменты разработчика на обычных формах 8.2.13+. Нужно выбрать тип запроса ADO, для которого будет доступен конструктор запросов (непохожий на штатный), дерево запроса, контекстная подсказка и 1с-ная подсветка синтаксиса.
AlexiyI; speshuric; TeMochkiN; teflon; +4 Ответить
18. Чародей 17 29.02.16 08:51 Сейчас в теме
Скачал "Демонстрация работы с Excel через Табличный документ 1С" а он тоже только для управляемых форм ((
Может дополните описание?
19. Zerocl 576 29.02.16 11:21 Сейчас в теме
(18) Чародей, Так на алгоритм работы через табличный документ не влияет.
Я учту и дополню описание. Спасибо.
20. igormiro 707 29.02.16 13:39 Сейчас в теме
Спасибо за статью.
Единственное, что я хотел уточнить, для тех кто не знает, где можно скачать ODBC ODBC .
21. babys 83 06.03.16 15:33 Сейчас в теме
Автор:
Вот это что за шняга:
//Сразу отбираем только не пустые номенклатуры
ТекстЗапроса = "SELECT * FROM [Лист1$] WHERE `Номенклатура`<>""""";

Вы когда что-то пишите, пытайтесь думать не как 80-ти летний профессор и член-корр АН.
22. Zerocl 576 09.03.16 22:54 Сейчас в теме
(21) babys, Не пойму суть вашей претензии. Это SQL запрос к Excel он вроде как по Русски не понимает
25. babys 83 15.03.16 12:17 Сейчас в теме
(22) слово "Номенклатура" не смущает, в предложении where? Меня очень. Я привык писать
[F2] <> ""НДФЛ""
26. Zerocl 576 16.03.16 20:17 Сейчас в теме
он берет(25) babys, Он берет название из первой строки. Вариант в поле рабочий. Может конечно не привычный но это просто пример :)
23. Yashazz 3415 12.03.16 20:59 Сейчас в теме
На самом деле обзорчик не полный. С экселем можно работать ещё множеством разных способов. Можно, если современная версия, xml парсить, а можно SafeArray юзать. Ну и так далее.
28. Sirruf 138 27.07.16 17:41 Сейчас в теме
Подскажите, кто знает - как быстро вставить гиперссылки в экселевский файл?
Через COMОбъект("Excel.Application") при большом количестве строк, в которые нужно добавить Hyperlinks очень долго работает...
29. Sirruf 138 27.07.16 17:49 Сейчас в теме
Есть вообще какие-нибудь хорошие библиотеки для работы с файлами в формате xlsx помимо COMОбъект("Excel.Application"), который использовать вроде как не рекомендует Майкрософт?
30. dr-wit 5 30.08.16 08:58 Сейчас в теме
Спасибо, отличная статья!

Еще по группировкам данных на листе, если требуется заполнить подготовленный шаблон листа:
1. Развернуть все группы (строки и колонки):
Excel.ActiveSheet.Outline.ShowLevels(3, 3);

2. Сернуть все группы (строки и колонки) до первого уровня:
Excel.ActiveSheet.Outline.ShowLevels(1, 1);

31. Rustam1984 12.09.16 22:58 Сейчас в теме
Спасибо,
Взял на вооружение!
32. skyvixen 20 13.09.16 10:33 Сейчас в теме
Коллеги, кто может подсказать, как сохранить в Excel гиперссылку (например, в расшифровке ячейки табличного документа 1C у меня указан WEB-адрес)
33. goodwill 20 29.11.16 17:20 Сейчас в теме
Ширина в Excel задается в символах, что не очень удобно при выводе картинок. Вот функция для перевода ширины в пикселя в ширину в символах.

&НаКлиенте
Функция ПолучитьШиринуКолнкиЭксель(ПараметрШиринаВПикселях)
	
	Если ПараметрШиринаВПикселях > 9 Тогда 
		ШиринаВСимволах = (ПараметрШиринаВПикселях/0.75-5)/7;
	Иначе
		ШиринаВСимволах = ПараметрШиринаВПикселях/9;
	КонецЕсли;

	Возврат ШиринаВСимволах;
	
КонецФункции

Лист.Columns("A").ColumnWidth = ПолучитьШиринуКолнкиЭксель(РазмерШиринаВПикселях);
Показать
34. panovisp 29.11.16 17:25 Сейчас в теме
Спасибо за полезную информацю!
35. Gasilin 44 09.12.16 15:43 Сейчас в теме
Хорошая статья. Но вот пытаюсь на сервере рисовать диаграммы в Excel и при попытке соединения ПодключитьсяКExcelСервер(ИмяВременногоФайла) ругается: ...Open. Произошла исключительная ситуация (MS Excel). К сожалению, нам не удалось найти файл ... . Возможно, он был перемещен, переименован или удален?
Это проблема с отсутствием папки C:\Windows\SysWOW64\config\systemprofile\Desktop?
36. ImHunter 200 09.12.16 17:03 Сейчас в теме
Еще есть способ чтения Excel 2007-выше (*.xlsx) через XML. Ведь это зазипованный XML. В БСП это подсмотрел в обработке ЗагрузкаДанныхИзФайла.
42. su_mai 88 25.03.17 07:49 Сейчас в теме
(36) Структура файлов docx, xlsx и пр., соответствует спецификации Microsoft Open Packaging Convention, сокращенно OPC: https://en.wikipedia.org/wiki/Open_Packaging_Conventions.

По такому же принципу построены файлы комплектов бюджетной бухгалтерской отчетности 1С, для конфигураций БГУ и Свод отчетов (repx).
46. XelOla 17 30.03.17 15:54 Сейчас в теме
(42) Скажите, а можно с Эксель проработать как в статье http://infostart.blog-buh.ru/public/237032/
37. Gasilin 44 26.12.16 15:00 Сейчас в теме
Во втором случае на сервере в строке разве в качестве параметре должно выступать Объект.ИмяФайла?
Соединение = ПоключитьсяКExcelСервер(Объект.ИмяФайла);
38. roofless 22 09.01.17 10:42 Сейчас в теме
(37) код этой процедуры тут не приведен, так что вполне может быть и имя файла, если параметры подключения жестко заданы в коде
39. Gasilin 44 09.01.17 14:18 Сейчас в теме
Код процедуры есть в файле публикации.
Даю фрагмент:
&НаСервере
Процедура Загрузить2НаСервере(пФайл)

лФайл = ПолучитьИмяВременногоФайла("xlsx");
лДвоичДанные = ПолучитьИзВременногоХранилища(пФайл);
лДвоичДанные.Записать(лФайл);

Соединение = ПоключитьсяКExcelСервер(Объект.ИмяФайла);
Если Соединение = Неопределено Тогда
Возврат;
КонецЕсли;
47. =Kollega= 1 30.03.17 18:10 Сейчас в теме
(39) Сразу скажу - полный бред. Смотрите вы получаете имя временого файла в лФайл, куда и сохраняется сам файл. А потом пытаетесь открыть файл, который задан в реквизите объекта ИмяФайла. Я так полагаю это файл который пользователь выбрал на КЛИЕНТЕ. Соответственно открывать нужно именно лФайл, который сохранен во временном каталоге сервера.
Да и после окончания работы с ним, неплохо бы почистить за собой - удалить временный файл с сервера.
40. KazanKokos 8 21.03.17 09:36 Сейчас в теме
Народ. А как в Запросе T-SQL вытащить уровень группировки? При строчном переборе я уже научился и пользуюсь, но на больших файлах сами понимаете тормоза. Буду переходить на ODBC и хотелосьбы раскидывать по папкам
41. su_mai 88 25.03.17 07:45 Сейчас в теме
>Подключаемся к OLE и октрываем файл Excel:
Есть более удобный метод получения Com объекта: "ПолучитьCOMОбъект". Из СП: Основное применение функции ПолучитьCOMОбъект - это получение COM-объекта, соответствующего файлу. Доступность: Тонкий клиент, веб-клиент, сервер, толстый клиент, внешнее соединение.
43. BigBoss 3 26.03.17 10:51 Сейчас в теме
Полезно достаточно. Спасибо
44. spezc 669 26.03.17 10:56 Сейчас в теме
45. XelOla 17 30.03.17 13:55 Сейчас в теме
Скажите, а можно с Эксель проработать как в статье http://infostart.ru/public/237032/
48. su_mai 88 31.03.17 20:43 Сейчас в теме
(45) Можно только с форматом xslx.
49. pekus 25.04.17 09:12 Сейчас в теме
Можете еще добавить про установку сквозных строк:
ActiveSheet.PageSetup.PrintTitleRows = "$1:$4"

где $1 - номер первой строки, $4 - номер последней строки.

Была задача, чтобы шапка таблицы excel при выводе на печать отображалась на каждой странице. Пробовал использовать шаблон файла excel с настроенными сквозными строками, но после обработки в 1С и сохранения файла эта настройка пропадала. Долго искал как сделать эту настройку на стороне 1С - и вот нашел) Задача решена.
50. Key-Zed 108 14.09.17 11:09 Сейчас в теме
Подскажите, не могу найти метод как выделить несколько листов в книге, и сохранить к примеру в PDF.
51. creatermc 2 26.02.18 09:24 Сейчас в теме
Большой плюс автору и goodwill за материал, многое собрано в одном месте, все очень доступно и грамотно прописано
52. Bene_Valete 167 17.07.18 06:24 Сейчас в теме
Спасибо за публикацию, очень наглядно и содержательно
53. user609516_rrustam11983 01.08.18 07:00 Сейчас в теме
54. strelec13 13 24.10.18 17:46 Сейчас в теме
Может пропустил. Непонятно, неужели ни кто не сталкивался с проблемой перезаписи файла Эксель после его изменения. Вместо записи и закрытия файла, выводится системное сообщение о предложении перезаписи файла, вместо того, чтобы записаться и закрыться.
55. user790109 8 31.10.18 10:07 Сейчас в теме
Как определить какие строки ексель заполнены? Мне требуется зачищать ексель кроме 1 строки(т.к там наименования столбцов) и загружать туда новые данные
56. user790109 8 31.10.18 11:12 Сейчас в теме
Попытка
		Excel = Новый COMОбъект("Excel.Application");
		Excel.Application.DisplayAlerts = False;
		Excel.WorkBooks.Open(ИмяФайла);
		Excel.visible = Истина;

		Excel.Sheets("LRU_LET").Select();
		НС = 1;
		НК = 1;
		Excel.Range(Excel.Cells(2, 1), Excel.Cells(100, 3)).Delete();
		Для каждого стр Из ТЗ Цикл
			НС = НС + 1;
			Excel.Cells(НС, НК).Value = стр.ITEM;  
			Excel.Cells(НС, НК+1).Value = стр.DSCA;
			Excel.Cells(НС, НК+2).Value = стр.QHND;
		КонецЦикла;
		Excel.ActiveWorkBook.Save();

		Excel.DisplayAlerts = 0; 
		Excel.ActiveWorkbook.Close();
		Excel.DisplayAlerts = 1;
		Excel.Application.Quit();
		Excel = Неопределено;
	Исключение
		Сообщить("Ошибка при открытии файла с помощью Excel! Загрузка не будет произведена!");
		Сообщить(ОписаниеОшибки());
	КонецПопытки;
Показать

После выполнения, файл доступен только для чтения. В процессе заметил что visible остается Ложь, и процесс екселя остается активным(не удает удалить файл, пока не грохнешь процесс). Что я делаю не так?
58. Alex_1066 04.06.19 17:29 Сейчас в теме
Вопрос, а в примере клиент-серверного варианта строчка "ОтобразитьТабНаФорме(Таб);" что обозначает? Или другими словами - что там и как реализовано в этой процедуре/функции дальше?
59. Zerocl 576 04.06.19 21:47 Сейчас в теме
(58) Эта процедура отображает произвольную таблицу значений на форме
60. semx800 70 27.06.19 11:28 Сейчас в теме
Долго боролся с проблемой, не читался эксель в серверном варианте и проблема оказалась не в коде, а в экселе.

Решение тут https://infostart.ru/public/196323/ спасибо этому челу, и тебе конечно за статью.
Divedition; +1 Ответить
61. ignor 222 16.11.19 23:47 Сейчас в теме
Лист.Rows(Инд).OutlineLevel

Возвращает глубину для деревьев, то есть для сворачиваемых и разворачиваемых строк
63. pavel_pss 266 15.01.20 15:48 Сейчас в теме
Пример удаление листов в файле эксель. по списку из справочника Подарок :)





ДокExcel = ПолучитьCOMОбъект("", "Excel.Application");
ExcelФайл = ДокExcel.WorkBooks.Open(ИмяВременногоФайла);

Для Сч = 1 По ExcelФайл.Sheets.Count Цикл

Если Сч > ExcelФайл.Sheets.Count Тогда
Прервать;
КонецЕсли;

ИмяЛиста = ExcelФайл.Sheets(Сч).Name;

Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ
| СписокЛистовВФайлеЭксельДляУдаления.Ссылка КАК Ссылка,
| СписокЛистовВФайлеЭксельДляУдаления.Наименование КАК Наименование
|ИЗ
| Справочник.СписокЛистовВФайлеЭксельДляУдаления КАК СписокЛистовВФайлеЭксельДляУдаления
|ГДЕ
| СписокЛистовВФайлеЭксельДляУдаления.Используется = ИСТИНА
| И СписокЛистовВФайлеЭксельДляУдаления.Наименование = &Наименование";

Запрос.УстановитьПараметр("Наименование", ИмяЛиста);

Результат = Запрос.Выполнить();
Если НЕ Результат.Пустой() Тогда
ExcelФайл.Sheets(ИмяЛиста).Select();
ExcelФайл.ActiveSheet.Delete();

Сч = Сч - 1;
КонецЕсли;
КонецЦикла;

// начинаем закрывать файл
ДокExcel.DisplayAlerts = 0;

// сохраняем его в новый временный, для помещения во врем.хранилище на сервер
ИмяВременногоФайлаНовый = ПолучитьИмяВременногоФайла(ТипВыбранногоФайла); //"xlsx"
ExcelФайл.SaveAs(ИмяВременногоФайлаНовый);
ExcelФайл.Close();


ДокExcel.DisplayAlerts = 1;
ДокExcel.Quit();
ДокExcel = Неопределено;
64. snurk 7 14.02.20 03:48 Сейчас в теме
Несколько дополнений.

Работа с Excel-файлами через ТабличныйДокумент удобна, довольно быстра и кроссплатформенна, я предпочитаю именно её, но, к сожалению, тут есть ограничение - метод Прочитать() недоступен в тонком клиенте. Это кажется довольно нелогичным, т.к. тонкий клиент без проблем может открывать файлы Excel просто через меню Файл/Открыть, но это так.

Второе - по поводу работы с файлами, содержащими несколько листов, через ТабличныйДокумент. При загрузке листы файла преобразуются в именованные области. К сожалению, при этом 1С делает некоторые изменения имён листов - например, пробел заменяется на символ подчёркивания. Способа получить оригинальное имя листа при загрузке файла только средствами 1С, похоже, нет.

Наконец, последнее - есть малоизвестный объект ПакетОтображаемыхДокументов. Он очень удобен, когда надо сохранить файл Excel с несколькими листами и заданием их имён. Также этот объект хорош для печати, через него можно задать имя задания печати. К сожалению, через него нельзя прочитать файл.
65. 5H1 25.02.20 09:58 Сейчас в теме
ADODB.Command Для выполнения комманд на языке T-SQL

Как оказалось, это не совсем так. Используется язык Microsoft Access SQL. В нем нет множества полезных функций и методов, которые есть в T-SQL.

Например, я пытался добавить колонку ID (SEL ECT IDENTITY (int, 0, 1) AS ID), которая отсутствует в исходном excel-файле для того, чтобы отобрать нужные мне записи по ID, так как файл имеет достатоно много лишних полей. Как оказалось, напрямую это сделать нельзя.

Был составлен примерно такой запрос:

SEL ECT
	IDENTITY (int, 0, 1) AS ID
	, *
INTO #EXCEL
FR OM [EXCEL3]...[Page1$] AS EXCEL

SELECT * FR OM #EXCEL
WH ERE ID > 9
ORDER BY ID 

DR OP   TABLE #EXCEL
Показать


Который отлично отрабатывает в Microsoft SQL Server Management Studio 18, но не в 1С.

Если есть доступ к SQL серверу, можно открыть excel-файл запросом:

SELECT *
FR OM OPENROWSET(
    'Microsoft.ACE.OLEDB.12.0',
    'Excel 12.0;HDR=NO;Database=T:\temp\Test.xlsx',
    'select * fr om [sheet1$]')


И произвести дальнейшие манипуляции на стороне SQL сервера используя синатксис T-SQL, а не Microsoft Access SQL. Но теперь стоит вопрос целеобразности всего этого.

Если я не прав, поправьте меня.
66. noon 10 18.09.20 10:37 Сейчас в теме
Не нашел тут вроде, копирование диапазона ячеек:
исходныйДиапазон.Copy( диапазонВставки );
Может кому полезно будет.
Оставьте свое сообщение

См. также

"Процессы 3.0: CRM, Бизнес-процессы, Управление по целям". Универсальная система управления процессами и показателями для любой конфигурации 1С Промо

Управление бизнес-процессами (BPM) v8 1cv8.cf УУ Платные (руб)

"Процессы 3.0" - это подсистема для любой конфигурации 1С. Она управляет бизнес-процессами, считает показатели, зарплату сотрудников, создает интерфейсы. "Процессы" состоят из конструкторов, с помощью которых можно создавать бизнес-процессы, скрипты продаж, системы стимулирования, мотивации и многое другое без программирования.

48000 руб.

15.08.2014    57643    36    124    

Загрузка данных интернет банкинга БелВЭБ

Банковские операции Обмен с банком Банковские операции v8::БУ БП2.0 Беларусь БУ Абонемент ($m)

Загружает информацию из файла интернет банка БелВЭБ

1 стартмани

01.08.2018    7125    5    dedkov    2    

Проверка БСО сервисом blank.bisc.by

WEB v8 1cv8.cf Беларусь Абонемент ($m)

Обработка получает данные о наличии бланков строгой отчетности за организацией Республики Беларусь.

1 стартмани

25.07.2018    5829    3    keyn5565`    0    

Восстановление потерянных связей между контрагентами и контактами после обновления УНФ до версии 1.6.15

Обработка справочников v8::УФ УНФ Беларусь Россия Абонемент ($m)

Восстановление связей контрагент-контакт после обновления УНФ.

1 стартмани

05.07.2018    5108    21    lobodaeva    4    

Программа Дисплей покупателя: второй монитор (Информационное табло). Поддержка видео Промо

Управление торговлей Рабочее место Розничная торговля Розничная торговля Розничная и сетевая торговля (FMCG) Рестораны, кафе и фаст-фуд УУ Платные (руб)

Программа Дисплей покупателя: второй монитор (Информационное табло) предназначена для работы на любых кассах с различным кассовым программным обеспечением. Взаимодействие происходит с помощью текстовых файлов. На одной половине экрана крутятся изображения с вашей рекламой или акциями, на другой половине отображается текущий заказ покупателя. Фоновое изображение и рекламные картинки вы можете использовать свои. Приложение открывается на полный экран, скрывая панель Пуска. Можно запустить его на втором мониторе, подключенном к кассе или на отдельном компьютере, отправляя на него информацию по сети. Также в качестве дисплея удобно использовать планшет на Windows. Появилась возможность прокручивать видео-ролики со звуком во время простоев. Также можно отключить рекламу и выводить текстовую информацию на весь экран. В версии 2.0 появилась возможность отображать картинки товаров и изменять размер дисплея.

5500 руб.

27.11.2014    66193    59    8    

Справка о заработной плате для БП

Бухгалтерские Зарплата Справки Зарплата v8 v8::БУ БП3.0 Беларусь Россия БУ НДФЛ ФОМС, ПФ, ФСС Платные (руб)

Справка о заработной плате для конфигурации Бухгалтерия предприятия, а также аналогов!

2000 руб.

01.07.2018    93538    2    2    

Выгрузка курсов валют с сайта НБ РБ посредством API с графиками колебаний курсов

Универсальные обработки Обработка справочников v8 v8::БУ БП3.0 Беларусь Платные (руб)

Обработка выгрузки курсов валют с сайта НБ РБ посредством API с графиками колебаний курсов

1000 руб.

31.05.2018    9396    0    0    

Расширение для работы КА "Титан-А","Титан-A wi-fi", "Титан-ПЛЮС" с 1С:Предприятие 8

Фискальный регистратор Кассовые операции Кассовые операции v8 1cv8.cf Беларусь Платные (руб)

Расширение предназначено для работы кассового аппарата "Титан-А" ,"Титан-A wi-fi", "Титан-ПЛЮС" и конфигураций: "Управление торговлей для Беларуси" ред. 3.4 "Розница для Беларуси", ред.2.2 "1С:Комплексная автоматизация для Беларуси 2", ред.2.4 "1С:ERP Управление предприятием 2 для Беларуси", версия 2.4

3000 руб.

22.05.2018    19828    26    60    

Комплексная проверка ведения учета в УТ, КА, УПП, ERP, БП, УНФ, Рознице (с расшифровкой до документов) Промо

Анализ учета Управленческие Финансовые Дебиторская и кредиторская задолженность Закрытие периода Кассовые операции Комиссионная торговля Учет ТМЦ Учетная политика Дебиторская и кредиторская задолженность Закрытие периода Кассовые операции Комиссионная торговля Учет ТМЦ Учетная политика v8 КА1 БП2.0 УТ10 Розница УПП1 УНФ ERP2 УТ11 Беларусь Украина Россия Казахстан БУ УУ Платные (руб)

Комплект проверок ведения учета в УТ10, УТ11, КА, УПП, ERP, УНФ, Рознице по остаткам товаров, партиям товаров организаций, состоянию заказов и денежным средствам. Упрощает поиск и исправление ошибок при закрытии месяца. Отчет позволяет сверить данные в связанных регистрах накопления, проверить отрицательные остатки, найти зависшие суммовые остатки с нулевым количеством. По любой непонятной сумме можно выполнить расшифровку, перейти в отчет по движениям документов, по которым эта сумма образовалась и сверить, откуда появилась проблема.

3000 руб.

04.12.2015    106806    473    177    

Клиент ЕРИП

Внешние источники данных v8 1cv8.cf Беларусь Абонемент ($m)

Встроенный в Управление Компанией для Беларуси клиент для выставления требований и загрузки платежей ЕРИП. Упрощает взаимодействие с сервером ЕРИП.

1 стартмани

20.05.2018    6006    5    liurn    0    

Преобразование текста JSON в дерево значений. УФ (8.3)

Инструментарий разработчика v8 v8::УФ 1cv8.cf Беларусь Абонемент ($m)

Последнее время часто начал сталкиваться с форматом  JSON, и возникла необходимость быстро анализировать те или иные данные в этом формате, отбрасывая ненужные, но при больших объёмах данных зачастую было сложно разобраться в структуре. Так что это обработка для тех, кто хочет увидеть JSON в читабельном виде (знаю, похожие обработки есть на Инфостарте, но для моих данных они все вываливались с ошибками). Обработка ни на что не претендует и сделана исключительно в целях сэкономить время для анализа JSON.

1 стартмани

26.04.2018    7436    28    burni4    5    

Обмен с интернет банком БПС-Сбербанк

Банковские операции Обмен с банком Банковские операции v8 v8::БУ 1cv8.cf Беларусь БУ Абонемент ($m)

Представляет собой надстройку над стандартным обменом с клиентом банка Бухгалтерии для Беларуси 2.1, позволяет производить загрузку выписок из системы интернет банк БПС-Сбербанк

1 стартмани

22.04.2018    8892    16    liurn    1    

Помощник работы с залежавшимся товаром и неликвидами Промо

Управленческие Оптовая торговля Розничная торговля Учет ТМЦ Рабочее место Оптовая торговля Розничная торговля Учет ТМЦ v8::ОУ УТ10 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика УУ Платные (руб)

Обработка будет полезна всем, кто заинтересован в избавлении от неликвидов и повышении оборачиваемости. Залежавшийся товар может быть найден различными способами (по коэфф. оборачиваемости, сроку с момента поступления). А на полученный список можно назначить скидки, новую цену, ценовую группу и выполнить другие действия. Для 1С: Управление Торговлей 10.3

3000 руб.

22.09.2014    58301    108    76    

Правила конвертации данных 7.7 - БП 8.3

Перенос данных из 1С7.7 в 1C8.X v8 1cv8.cf Беларусь БУ Абонемент ($m)

Правила конвертации данных при переходе с конфигураций с 7.7 на Бухгалтерию 2.1 (Беларусь)

2 стартмани

21.04.2018    8063    4    brunet    3    

Загрузка справочника БИК банков с сайта Национального банка Республики Беларусь http://www.nbrb.by для конфигураций 1С 7.7 используя AddIn.V7HttpReader с разбором файла ответа в формате JSON

Обработка справочников Банковские операции Банковские операции v7.7 1С7:Бух Беларусь БУ Абонемент ($m)

Обработка для загрузки справочника БИК банков с сайта Национального банка Республики Беларусь. Пример скачивания файла из интернет из 1С 7.7, пример простого разбора файла JSON из 1С 7.7.

1 стартмани

07.04.2018    12342    3    svilsa    2    

Решение проблемы отображения интерфейса Такси на экранах с маленьким разрешением

Работа с интерфейсом v8 v8::УФ Беларусь Бесплатно (free)

Решение возникшей проблемы при переходе с интерфейса 8.2 на интерфейс Такси на экранах с маленьким разрешением.

06.04.2018    12995    Drak87    18    

1С:Управление сервисным центром Промо

Управление услугами и сервисом v8 Бытовые услуги, сервис Россия УУ Платные (руб)

Использование конфигурации "1С:Предприятие 8. Управление сервисным центром" позволит решить основные задачи по учету и управлению работой сервисного центра. В основу положена конфигурация Управление небольшой фирмой, так же продукт содержит все возможности и механизмы, реализуемые типовым решением. Использование приложения позволит управлять информационной системой для оказания услуг по гарантийному ремонту, обслуживанию бытовой и компьютерной техники, а так же различного оборудования. Программа "1С:Предприятие 8. Управление сервисным центром" предоставляет пользователям ключевые возможности: проведение анализа, планирования и гибкого управления ресурсами компании; оптимизации эффективности ежедневной работы во всех направлениях; проведение технического обслуживания наличного оборудования; предоставление услуг гарантийного и негарантийного ремонта; обслуживание компьютерной и бытовой техники.

26400 руб.

17.02.2016    23836    1    10    

Обновление списка отозванных сертификатов. 1С:Бухгалтерия для Беларуси, редакция 2.1

Обработка справочников WEB v8 1cv8.cf Беларусь БУ Абонемент ($m)

Расширение конфигурации для обновления списка отозванных сертификатов Министерства по налогам и сборам Республики Беларусь и Национальныого центра электронных услуг, для Бухгалтерии для Беларуси, редакция 2.1.

1 стартмани

28.02.2018    7976    1    ilya.rudziak    0    

Импорт выписки за день из интернет-банка "Банк Решение" (Трастбанк) Минск в 1С: Бухгалтерия 7.7

Банковские операции Обмен с банком Банковские операции v77::БУ 1С7:Бух Беларусь БУ Абонемент ($m)

Загружает выписку за день из файла экспорта интернет-банка "Банк Решение" (*.txt) в документ "Выписка" конфигурации 1С: Бухгалтерия 7.7 (7.70.170426) с поиском контрагента по УНП.

1 стартмани

02.02.2018    10046    1    silver30    5    

Импорт таможенных деклараций из программы "Декларант-2011" (РБ) для БП 2.0

Универсальные обработки Внешнеэкономическая деятельность (ВЭД) Внешнеэкономическая деятельность (ВЭД) v8::БУ 1cv8.cf Беларусь БУ Абонемент ($m)

Обработка предназначена для импорта данных из системы "Декларант-2001" (ТаможПроектСофт). Также есть возможность создать номенклатуру, документы поступления, документы доп. расходов. Конфигурация тестировалась на конфигурации "Бухгалтерия для Беларуси, редакция 2.1. Локализация для Республики Беларусь: СООО '1С-Минск' (2.1.19.3) ", версия платформы '8.3.10.2650'.

1 стартмани

29.12.2017    13365    2    c1nil    0    

Конфигурация "Весовая" ред. 3.0 для Платформы 8.3 Промо

Оптовая торговля Производство готовой продукции (работ, услуг) Розничная торговля Учет ОС и НМА Учет ТМЦ Оптовая торговля Производство готовой продукции (работ, услуг) Розничная торговля Учет ОС и НМА Учет ТМЦ v8 Транспорт, автопарки, такси Беларусь Украина Россия Казахстан УУ Платные (руб)

Конфигурация "Весовая" ред. 3.0 для "1С:Предприятие 8.3" - это решение для организации контроля движения грузов через весовую и остатков на складах предприятий, занимающихся: - сельскохозяйственной деятельностью; - тепличных комплексов; - добывающей и горнодобывающей деятельностью; - производителей бетона и асфальта; - дорожно ремонтно-строительных управлений; - торговых организаций; - речных и морских портов осуществляющих перевалку груза; - и организаций, использующих весовую. Конфигурация реализована полностью в интерфейсе "Такси".

3000 руб.

24.03.2015    72256    89    65    

Загрузка банков в конфигурацию УНФ для Беларуси

Классификаторы Банковские операции Обработка справочников Банковские операции v8 v8::УФ 1cv8.cf Беларусь Абонемент ($m)

Загрузка справочника банков для конфигурации Управление компанией для Беларуси (ранее УНФ). Классификатор обновлен для использования счетов в формате IBAN и SWIFT кодов банков. Тестировалось на версии УНФ для Беларуси 1.6.9.2

1 стартмани

14.11.2017    12238    2    Kim1C    2    

Выгрузка ЭСЧФ из Бухгалтерии 3.0 для Беларуси в XML

Обмен через XML Оптовая торговля Производство готовой продукции (работ, услуг) Оптовая торговля Производство готовой продукции (работ, услуг) v8 БП3.0 Беларусь БУ Абонемент ($m)

Обработка позволяет выгружать сформированные в БП 3.0 для Беларуси счета-фактуры в XML, как это делалось раньше в 77. По разным причинам, не всегда получается настроить полноценное взаимодействие с сайтом, поэтому часто требуется выгрузка XML.

1 стартмани

10.10.2017    12496    7    fixin    0    

Обработка для загрузки пробитых чеков из кассы Штрих-МPAY-Ф в Бухгалтерию 8.3 (редакция 3.0) из файла PosTransactions.rep

ККМ Кассовые операции Кассовые операции v8 v8::БУ БП3.0 Беларусь Украина Россия БУ Абонемент ($m)

С помощью данной обработки можно загрузить из кассы Штрих-МPAY-Ф пробитые чеки в Бухгалтерию 1С 8.3 (редакция 3.0).

1 стартмани

02.09.2017    14065    5    ariyacom    0    

Управление тендерным отделом Промо

Управленческий учет (прочее) v8 Государственные, бюджетные структуры Россия Платные (руб)

Бизнес-решение на платформе 1С: Предприятие для автоматизации тендерного отдела. Программа предназначена для всех участников тендеров, выступающих в качестве поставщика товаров и услуг.

10000 руб.

31.10.2016    36011    3    49    

Как распознать правильного ИТ-специалиста?

О жизни Россия Бесплатно (free)

Одна из самых распространенных проблем в ИТ – нехватка квалифицированных специалистов. С ней сталкиваются абсолютно все. В статье раскрыты технологии и подходы подбора ИТ-специалиста.

29.08.2017    15855    KonstantaNN    254    

Экзорцизм программистскими методами

О жизни Бесплатно (free)

Примеры из жизни о том, как инструменты на платформе 1С помогают компании изгонять зло.

24.08.2017    34255    1c-intelligence    59    

Печать первичных документов для бухгалтерского учета. (Республика Беларусь)

Печатные формы документов Документооборот и делопроизводство Документооборот и делопроизводство v8 1cv8.cf Беларусь БУ НДС Абонемент ($m)

Конфигурация для печати первичных документов бухгалтерского учета(РБ).( Расходные накладные(ТТН-1, ТН-2(Вертикальные и горизонтальные с приложением)),счет-фактура, доверенность, платежные поручения и требования, реестр платежных требований, а так же объявление на взнос наличными.

1 стартмани

25.07.2017    8890    1    vlalisol    0    

Конфигурация "Управление мини-отелем" Промо

Управление услугами и сервисом Управление взаимоотношениями с клиентами (СRM) Дебиторская и кредиторская задолженность Производство готовой продукции (работ, услуг) Управление взаимоотношениями с клиентами (СRM) Дебиторская и кредиторская задолженность Производство готовой продукции (работ, услуг) v8 Гостиничный бизнес УУ Платные (руб)

Конфигурация для автоматизации учета работы мини-отеля или хостела. Конфигурация максимально проста, что позволяет приступить к работе максимально быстро! Достаточно посмотреть 9-ти минутное видео, в котором показаны основные принципы работы с конфигурацией. Разработана на управляемых формах. Код открыт, при необходимости конфигурацию можно дорабатывать под свои нужды.

7000 руб.

30.09.2015    28658    10    30    

Справочник банков РБ с новыми кодами БИК и обработка загрузки для него в 1С: 8

Обработка справочников Банковские операции Банковские операции v8 1cv8.cf Беларусь БУ Абонемент ($m)

Справочник банков РБ с новыми кодами БИК и старыми МФО. Обработка загрузки для него в 1С 8 Бухгалтерия, УТ, УНФ.

1 стартмани

20.07.2017    12849    27    MOHCTP    2    

Универсальная конвертация счетов в IBAN и обратно (обычная и управляемая форма)

Универсальные обработки Обработка справочников Банковские операции Банковские операции v8 v8::УФ 1cv8.cf Беларусь Абонемент ($m)

На пороге переходный период для внедрения номеров счетов в формате IBAN. Но если вы все пропустили - не беда, переход занимает пару минут! Читай далее, как это сделать...

1 стартмани

01.07.2017    13467    9    Xershi    6    

Загрузка новых лицевых счетов работников для Бухгалтерии для Беларуси 1.6 и Зарплаты и Управление Персоналом для Беларуси 2.5

Обработка документов Загрузка и выгрузка в Excel Зарплата Зарплата v8 1cv8.cf Беларусь БУ Абонемент ($m)

Из файла «*. xls(xlsx)», содержащего старый и новый лицевые счета, обработка ищет по старому лицевому счету документ "Заявка на открытие счетов" и в соответствующей строке меняет на новый.

1 стартмани

30.06.2017    5290    0    visusby    0    

Adaptersoft : Управление Сбором Данных. Получение сводной отчетности в базе 1С из однотипных файлов Excel Промо

Загрузка и выгрузка в Excel Управление холдингом (CPM) Управление холдингом (CPM) v8 УУ Платные (руб)

Управление Сбором Данных — конфигурация на 1С 8.2 для получения сводной отчетности в базе 1С из однотипных файлов Excel. Отлично подходит для организации оперативного или управленческого учета. Сочетает в себе гибкость ms Excel с защищенностью данных в 1С. Простая, понятная и доступная система в отличие от 1С:Консолидации или 1С:Свод отчетов.

15000 руб.

25.09.2014    21059    2    8    

Перевод банковских счетов в международный формат IBAN

Обработка справочников Банковские операции Банковские операции v77::БУ 1С7:Бух Беларусь Абонемент ($m)

Данная обработка предназначена для перевода старых банковских счетов (13 знаков) в международный формат IBAN (28 знаков) (для 1C:7.7)

2 стартмани

29.06.2017    8691    0    novichok20    0    

Перевод старых счетов в формат IBAN Беларусь для 1С Бухгалтерии 1.6.73.23 и старше

Обработка справочников Банковские операции Банковские операции v8::БУ 1cv8.cf Беларусь БУ Абонемент ($m)

Обработка позволяет выгрузить ваши расчетные счета в специальном формате и при помощи сайта НБРБ преобразовать номера счетов в формат IBAN

1 стартмани

26.06.2017    5720    3    kejsi    5    

Универсальная конвертация для 1C 7.7 Беларусь: счетов/кодов банка в IBAN/BIC через сервис iban.bisc.by

Обработка справочников Банковские операции Банковские операции v7.7 1cv7.md Беларусь БУ Абонемент ($m)

Обработка создана для упрощения перехода расчётных счетов и кодов банка в Беларуси с 4 июля 2017 г. на международный формат IBAN и BIC.

1 стартмани

21.06.2017    15106    11    1v7    6    

[ECDO] Отсылка писем из 1С без проблем - одна из лучших разработок! Промо

Email Управление взаимоотношениями с клиентами (СRM) Управление взаимоотношениями с клиентами (СRM) v7.7 1cv7.md Россия Платные (руб)

1600 пользователей - не могут ошибаться! Отсылка писем из среды 1С без использования почтовых агентов и без использования внешних компонент. Не требуется никаких изменений в конфигурации - взял, и пользуйся. Возможно ведение списка адресатов, ведение набора стандартных тем для писем и ведение стандартных текстов писем; поддерживается присоединение файлов к письму и их архивирование.

1000 руб.

08.06.2006    61490    54    241    

Обработка для пакетной выгрузки и загрузки расчетных счетов в формате IBAN и БИК SWIFT для сервиса "Калькулятор IBAN" НБ РБ"

Обмен с банком Банковские операции Банковские операции v8 1cv8.cf Беларусь БУ Абонемент ($m)

Выгрузка старых и загрузка новых расчетных счетов в формате IBAN и БИК SWIFT с помощью сервиса "Калькулятор IBAN" НБ РБ (http://iban.bisc.by).

1 стартмани

20.06.2017    7223    4    visusby    8    

Получение и загрузка новых номеров расчетных счетов контрагентов в формате IBAN с сайта НБ (Бухгалтерия для Беларуси, редакция 2.1.)

Обработка справочников Банковские операции Банковские операции v8 v8::БУ 1cv8.cf Беларусь БУ Абонемент ($m)

В связи с тем что, в Беларуси с 04.07.2017 года вводится новый формат банковских счетов, необходимо быстро заменить банковские счета контрагентов на новые. По спискам старых счетов получаем новые счета на сайте НБ и загружаем их в базу.

2 стартмани

20.06.2017    8756    7    iliba    3    

v77. Выгрузка и загрузка расчетных счетов в формате XML для сервиса "Калькулятор IBAN" НБ РБ

Обмен через XML Банковские операции Банковские операции v7.7 1cv7.md Беларусь БУ Абонемент ($m)

Выгрузка старых и загрузка новых расчетных счетов в формате XML во взаимодействии с сервисом "Калькулятор IBAN" НБ РБ (http://iban.bisc.by) Представлены две обработки: 1. IBtoIBAN - выгрузка старых номеров расчетных счетов. 2. IBANtoIB - загрузка новых номеров формата IBAN. Назначение: облегчить труд бухгалтера по изменению номеров счетов в справочниках "Банковские счета" предприятия и "Расчетные счета" контрагентов.

1 стартмани

17.06.2017    14362    3    item    0    

Путевые листы для легкового автомобиля Промо

Управленческий учет (прочее) v8 Автомобили, автосервисы Платные (руб)

Заполнение путевого листа и его расчет топлива согласно пройденному маршруту.

1500 руб.

09.06.2014    23605    7    14    

Загрузка расчетных счетов в формате IBAN

Обработка справочников Загрузка и выгрузка в Excel Банковские операции Банковские операции v8::БУ 1cv8.cf Беларусь БУ Абонемент ($m)

Загрузка новых номеров расчетных счетов контрагентов в формате IBAN.

1 стартмани

17.06.2017    8797    3    xzfantom    0    

Проверка счетов IBAN Беларусь

Универсальные обработки Банковские операции Банковские операции v8 1cv8.cf Беларусь БУ Абонемент ($m)

С 04.07.2017 в Беларуси вводится новая нумерация банковских счетов. Обработка поможет расчитать контрольную цифру, и проверить введенный счет на правильность. + Небольшое количество инфы по переходу

1 стартмани

11.05.2017    11849    3    GOshaSaveiko    15    

COM соединения с базами 1С на различных версиях платформы "Без перерегистрации и СМС"

Администрирование данных 1С v8 1cv8.cf Абонемент ($m)

Описание способа подключения к базам 1С с помощью ComConnector, на различных версиях платформы.

1 стартмани

16.04.2017    77968    245    WizaXxX    55    

Такие разные франчайзи, или как мы делаем большие проекты на 1С. Часть первая: ты помнишь, как всё начиналось

Управление проектом Бесплатно (free)

Недавно была написана статья о том, как работает мотивация персонала. Материал получил активный отклик у читателей Инфостарта, на форуме развернулась дискуссия, которая в итоге была достаточно далека от содержимого исходной статьи и свелась к критике самой идеи работы во франчайзи. Чтобы как-то ответить на эту критику, хотелось бы более подробно рассказать о том, что такое современный франчайзи и как он устроен. Но начнем мы с истории этого вида бизнеса, глазами рядового специалиста. Автор статьи Андрей Мироненко.

10.04.2017    31924    1СERP    107    

Мотивация персонала в фирмах франчайзи: а она работает?

Управление проектом Бесплатно (free)

Думаем, что практически любого работающего человека интересует вопрос мотивации. Этой проблемой в одинаковой степени озабочены работники и работодатели: как мотивировать людей, сколько платить, как платить, какая часть оплаты должна быть фиксированной, а какая зависеть от результата работы, как это всё повлияет на результаты работы, стоит ли быть строгим и дотошным руководителем или нужно активно делегировать полномочия подчиненным. ВЦ "Раздолье" провело небольшое исследование на тему мотивации и вот его результат. Автор статьи Андрей Мироненко.

03.04.2017    42665    1СERP    231    

Груповая загрузка данных о контрагенте с портала nalog.by по УНП

Обработка справочников WEB v8 УТ10 БП1.6 Беларусь Абонемент ($m)

Предназначена для ГРУППОВОЙ (все аналоги, что видел, работают лишь с одним УНП) загрузки информации с сайта gov.nalog.by Цель обработки - определить контрагентов ликвидированных и находящихся в стадии ликвидации для своевременного отражения в бух.учете расходов, понесенным по долгам по данным контрагентам. (Для справки: Должны уйти на убытки в тот же квартал, когда ликвидировали)

2 стартмани

23.03.2017    9177    3    vova196    1    

Загрузка классификатора банков Беларуси (с сайта - национального банка Беларуси)

Банковские операции Классификаторы Банковские операции v8::БУ v8::УФ БП3.0 Беларусь Абонемент ($m)

Обработка, позволяющая загружать новую информацию напрямую с сайта www.nbrb.by - Национального Банка Беларуси.

1 стартмани

04.03.2017    16194    35    dijee    10    

Главная книга по субсчетам c компактной печатью для 1С 8.2 БП 1.6

Бухгалтерские Оборотно-сальдовая ведомость, Анализ счета Оборотно-сальдовая ведомость, Анализ счета v8 БП1.6 Беларусь БУ Абонемент ($m)

Главная книга для 1С 8.2 БП 1.6. Проверена работа в конфигурации "Бухгалтерия для Беларуси. Редакция 1.6."

1 стартмани

04.03.2017    6237    5    dragonga    0    

Консоль сравнения данных (1С 8, 1С 7.7, SQL, CSV, TXT, DBF, XLS, DOC, XML, JSON, табличный документ) (версия 15.4.55)

Универсальные обработки v8 1cv8.cf Абонемент ($m)

Обработка Консоль сравнения данных (КСД) предназначена для сравнения данных, полученных из разных источников данных: информационных баз 1С 8, 1С 7.7, баз данных SQL, файлов формата CSV/TXT/DBF/XLS/DOC/XML, строки JSON, вручную заполненного табличного документа. Минимально необходимая версия платформы: 8.3.6.1977.

1 стартмани

13.02.2017    33101    120    sertak    99    

Управление пользователями и ролями пользователей

Информационная безопасность v8 1cv8.cf Беларусь Абонемент ($m)

Добрый день. Первая публикация, может, кому понадобится. Возникла идея сделать ее после того, как свернули базу и "порезали" права пользователям. Чтобы в конфигуратор не бегать каждый раз по звонку, сделал из 1С. Критику только приветствую!

1 стартмани

23.01.2017    9950    8    serg-lom89    2