Консоль запросов + ТЗ как параметры

Публикация № 78001

Разработка - Инструментарий разработчика - Консоль запросов

Стандартная консоль запросов, с добавленной возможностью использования описания/заполнения/использования таблиц значений как параметров. Совместима с настройками базовой консоли. Упрощает отладку запросов, использующих временные таблицы.

Ничего сверхестественного - стандартная консоль запросов, с добавленной возможностью использования описания/заполнения/использования таблиц значений как параметров, включающая в себя возможность получения данных временных таблиц под отладчиком в качестве парамеров.

___________

14.05.2019

Добавлена возможность импорта файла, сохраненного при серверном выполнении.

Добавлена закладка "Промежуточные результаты". Позволяет выполнить запрос через функцию  Запрос.ВыполнитьПакетСПромежуточнымиДанными() и вывести данные сложного запроса в виде массива результатов.

 

result_array

 

Упрощена функция получения параметров таблиц в связи с расширением платформенных возможностей по анализу содержимого менеджера временных таблиц.

 

 

Функция АСТ_Сохранить(ТЗ, ИмяФайла = "", Опция = Неопределено) Экспорт
    // создана для удобства переноса таблиц или запросов в консоль запросов - скидывает тз во внешний файл, который можно вычитать консолью запросов
    ЗаписьXML = Новый ЗаписьXML;
    Если ПустаяСтрока(ИмяФайла) Тогда
        ИмяФайла = КаталогВременныхФайлов() + ?(ТипЗнч(ТЗ) = Тип("ТаблицаЗначений"), "copytz.xml", "copyreq.xml") ;
    КонецЕсли;
    Если ТипЗнч(ТЗ) = Тип("Запрос") Тогда
        
        Зн = Новый Структура("Текст, Параметры", ТЗ.Текст, ТЗ.Параметры);
        МассивТаблиц = Новый Массив;

        Если ТипЗнч(Опция) = Тип("Строка") Тогда
            ////////// если опция - строка - значит считаем что передается точный перечень таблиц   
            // прямой перечень таблиц уже не нужен - но оставим если вдруг нежелательно все содержимое менеджера тащить 
            Вр = СокрЛП(Опция);
            Пока СтрНайти(Вр, ",") > 0 Цикл
                Имя = СокрЛП(Лев(Вр,СтрНайти(Вр, ",") - 1));
                Если СтрДлина(Имя) > 0 Тогда
                    МассивТаблиц.Добавить(Имя);
                КонецЕсли;
                Вр = СокрЛП(Сред(Вр, СтрНайти(Вр, ",") + 1));
            КонецЦикла;
            Если СтрДлина(Вр) > 0 Тогда
                МассивТаблиц.Добавить(Вр);
            КонецЕсли;
        ИначеЕсли ТЗ.МенеджерВременныхТаблиц <> Неопределено Тогда //Если Опция = Истина Тогда
            Для каждого Вр из ТЗ.МенеджерВременныхТаблиц.Таблицы Цикл
                МассивТаблиц.Добавить(Вр.ПолноеИмя);
            КонецЦикла;
            // любое другое значение позволяет просто вытащить запрос без временных таблиц 
        КонецЕсли;
        
        // пробуем вытащить значения в параметры
        Для каждого Тб из  МассивТаблиц Цикл
            ТЗВрем = ТЗ.МенеджерВременныхТаблиц.Таблицы.Найти(Тб);
            Если ТЗВрем <> Неопределено Тогда
                Зн.Параметры.Вставить(Тб, ТЗВрем.ПолучитьДанные().Выгрузить());
                Т = "// '" + Тб  + "' таблица вытащена из менеджера временных таблиц и помещена как параметр"  + Символы.ПС;;
                Т = Т + "ВЫБРАТЬ " ;
                Для каждого Кол из Зн.Параметры[Тб].Колонки Цикл
                    Т = Т + Символы.ПС + Символы.Таб + Тб + "." + Кол.Имя + " КАК " + Кол.Имя + "," ;
                КОнецЦикла;
                Т  = Лев(Т, СтрДлина(Т) - 1);
                Т = Т + Символы.ПС + "ПОМЕСТИТЬ " + Тб ;
                Т = Т + Символы.ПС + "ИЗ" + Символы.ПС + Символы.Таб + "&" + Тб + " КАК " + Тб + Символы.ПС + ";" + Символы.ПС + "//////////////////////////////////////////////////////////" + Символы.ПС+ Символы.ПС;
                
                Зн.Текст = Т + Зн.Текст; 
                
            КонецЕсли;
        КонецЦикла;
        
        
    ИначеЕсли ТипЗнч(ТЗ) = Тип("МакетКомпоновкиДанных") Тогда
        Запрос = Новый Запрос;
        Для каждого Параметр из ТЗ.ЗначенияПараметров Цикл
            ЗначПарам = Неопределено;
            Если ТипЗнч(Параметр.Значение) = Тип("СписокЗначений") Тогда
                ЗначПарам = Новый СписокЗначений;
                ЗначПарам.ЗагрузитьЗначения(Параметр.Значение.ВыгрузитьЗначения());
            Иначе
                ЗначПарам = Параметр.Значение;
            КонецЕсли;
            Запрос.УстановитьПараметр(Параметр.Имя,ЗначПарам);
        КонецЦикла;
        
        // определимся с набором
        Если ТипЗнч(Опция) <> Тип("НаборДанныхЗапросМакетаКомпоновкиДанных") Тогда
            // набор явно не указан - пробуем подобрать первый попавшийся набор запрос
            Для каждого Нб из ТЗ.НаборыДанных Цикл
                Если ТипЗнч(Нб) = Тип("НаборДанныхЗапросМакетаКомпоновкиДанных") Тогда
                    Опция = Нб;
                    Прервать;
                КонецЕсли;
            КонецЦикла;
        КонецЕсли;
        
        Если ТипЗнч(Опция) = Тип("НаборДанныхЗапросМакетаКомпоновкиДанных") Тогда
            Запрос.Текст = Опция.Запрос;
            Для каждого Параметр из Опция.ЗначенияПараметров Цикл
                ЗначПарам = Неопределено;
                Если ТипЗнч(Параметр.Значение) = Тип("СписокЗначений") Тогда
                    ЗначПарам = Новый СписокЗначений;
                    ЗначПарам.ЗагрузитьЗначения(Параметр.Значение.ВыгрузитьЗначения());
                Иначе
                    ЗначПарам = Параметр.Значение;
                КонецЕсли;
                Запрос.УстановитьПараметр(Параметр.Имя,ЗначПарам);
            КонецЦикла;
        КонецЕсли;
        Зн = Новый Структура("Текст, Параметры", Запрос.Текст, Запрос.Параметры);
    Иначе
        Зн = ТЗ;    
    КонецЕсли;
    ЗаписьXML.ОткрытьФайл(ИмяФайла, "UTF-8");
    
    #Если Не ТонкийКлиент И НЕ ВебКлиент Тогда
        СериализаторXDTO.ЗаписатьXML(ЗаписьXML, Новый ХранилищеЗначения(Зн ,Новый СжатиеДанных(9)));
    #КонецЕсли
    
    ЗаписьXML.Закрыть();
    Возврат Истина;
КонецФункции

 


03.09.2015

В функции получения запроса в режиме отладки добавлена возможность автоматического определения используемых временных таблиц (переданных через менеджер запросов) и помещения их значений в соответствующий параметр.

Для определения состава временных таблиц осуществляются попытки выполнить запрос, с последующим анализом ошибки (в случае системных сообщений платформы на отличном от русского языка - требуется внести соответствующую правку в текст функции).

Также стоит учитывать, что в процессе автоматического анализа будет запрос будет единожды выполнен. Если само по себе выполнение запроса вызывает проблемы (зависает / либо слишком долго), используйте явное указание списка необходимых временных таблиц.

 

Получение запроса со временными таблицыми под отладчиком

15.11.2013

Данная редакция функции сохранения под отладчиком расширяет возможность отладки сложных запросов, использующих таблицы из менеджеры временных таблиц - в качестве третьего параметра позволяет указывать имена временных таблиц (через запятую), используемых в запросе. Содержимое временных таблиц которых при этом  будет вычитано из менеджера и использовано как параметр-таблица значений.

В качестве экзотического дополнения,  можно указывать МакетКомпоновкиДанных как источник запроса. В этом случае будет запрос будет извлечен из первого набора данных макета, либо можно указать конкретный набор в качестве третьего параметра.

15.11.10/2 Можно использовать результаты выполнения запроса как основание для создания структуры ТЗ и заполнения данными.


23.11.11/1 Добавлена возможность выгружать таблицы в файл / из файла.

10.04.11/1 Добавлена возможность выгружать запросы с параметрами (в т.ч. таблицы значений) в файл / из файла


Для выгрузки таблиц/запросов из конфигуратора в режиме отладки добавьте и используйте функцию

Функция EWG_Сохранить(ТЗ, ИмяФайла = "") Экспорт
    ЗаписьXML = Новый ЗаписьXML;
    Если ПустаяСтрока(ИмяФайла) Тогда
        ИмяФайла = КаталогВременныхФайлов() + ?(ТипЗнч(ТЗ) = Тип("Запрос"), "copyreq.xml", "copytz.xml") ;
    КонецЕсли;
    Зн = ?(ТипЗнч(ТЗ) = Тип("Запрос"), Новый Структура("Текст, Параметры", ТЗ.Текст, ТЗ.Параметры), ТЗ);
    ЗаписьXML.ОткрытьФайл(ИмяФайла, "UTF-8");
    СериализаторXDTO.ЗаписатьXML(ЗаписьXML, Новый ХранилищеЗначения(Зн ,Новый СжатиеДанных(9)));
    ЗаписьXML.Закрыть();
    Возврат Истина;
КонецФункции


 

Примеры обращения под отладчиком  :

EWG_Сохранить(НекийЗапрос.Выполнить().Выгрузить()); // будет выгружена таблица результатов запроса

EWG_Сохранить(НекийЗапрос); // будет выгружен текст запроса с параметрами и всеми используемыми временными таблицами

EWG_Сохранить(НекийЗапрос,, "ВТКонтрагенты, ВТДокументы"); // будет выгружен текст запроса с параметрами плюс времененные таблицы, соответствующие указанным.

 

 

Таблицы в консоль подгружаются через выбор пункта меню консоли "Импорт из файла по-умолчанию" на закладке ТЗ-параметры.

Запросы подгружаются через выбор пункта меню консоли "Импорт из файла по-умолчанию" на основной панели формы, либо через контекстное меню дерева запросов.

 

28.08.12 Мелкие косметические изменения в т.ч. вывод количество строк результата выполнения запроса.

 

Скачать файлы

Наименование Файл Версия Размер
Консоль для 8.3

.epf 106,32Kb
14.05.19
434
.epf 070213 106,32Kb 434 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо развёрнутое
Свернуть все
1. fierylions 05.02.11 09:30 Сейчас в теме
а как её запустить если в самом конфигураторе то просто код показывает если в предприятии то пустое окошечко
2. vec435 15 11.04.12 10:15 Сейчас в теме
при отладке из конфигуратора тз выгружается как отдельный файл или добавляется в параметры?
3. Kashemir 351 11.04.12 11:54 Сейчас в теме
Выгружается в отдельный файл, который можно загрузить в консоли как значение параметра
8. Bukaska 133 15.11.13 14:24 Сейчас в теме
(3) Это консоль для обычного приложения?(ТолстыйКлиент) или для управляемого приложения?(Тонкий клиент)
А то для обычного приложения я как то скачивала консоль: только загрузил запрос - консоль уже создала параметры, остается только ввести значения.
Вот бы для тонкого клиента что-нить такое.. А то другой раз запросы как простыня, чекнешься параметры искать)
9. Kashemir 351 15.11.13 14:34 Сейчас в теме
(8) Bukaska, для толстого клиента.
4. pvlunegov 156 20.04.12 11:28 Сейчас в теме
Спасибо автору за замечательную возможность работы с Таблицами Значений в качестве параметра запроса.
Единственная обработка (консоль запросов) на данном сайте, в которой ПОЛНОСТЬЮ реализована данная функция.

Есть даже сохранение ТЗ в файл запросов. Это просто замечательно!

Смотрел аналогичные консоли, там этой функции или нет, или урезанная, или атрофированная, или без сохранения таблицы в файл запросов.

Всем, кому надо работать с ТЗ и сохранять запросы в файл - рекомендую!
5. MakcTLT63 9 15.11.13 08:51 Сейчас в теме
Глянул скрины. У меня эта обработка хранится под именем EWG_Консользапросов.
Автор позаимствовал идею?
6. Kashemir 351 15.11.13 12:21 Сейчас в теме
(5) MakcTLT63, EWG это аббревиатура мой текущей фирмы. Идея и реализация собственная.
7. MakcTLT63 9 15.11.13 14:20 Сейчас в теме
(6)
Упс.. Прошу прощения за необоснованные подозрения.
Обработка лучшая.
Когда надо поработать с ТЗ она просто незаменима.
10. Kashemir 351 15.11.13 14:41 Сейчас в теме
(7) MakcTLT63, Приятно, что кому-то пригодилась :)
11. desarz 62 05.12.13 15:33 Сейчас в теме
12. sick_russian 05.02.14 06:25 Сейчас в теме
на скрине видно что колонке присваивается тип "СправочникСсылка.Номенклатура", а я такой тип выбрать не могу( почему?
13. Kashemir 351 10.02.14 19:37 Сейчас в теме
Подозреваю что в используемой конфигурации нет справочника "Номенклатура" :)
14. Nebiros777 5 25.02.14 13:31 Сейчас в теме
Удобная штука, постоянно подобной пользуюсь.
15. CaptainMorgan 14.03.14 12:58 Сейчас в теме
А вариант с управляемой формой возможен?
16. oyeah 14.01.15 02:35 Сейчас в теме
(15) CaptainMorgan, Вариант для УФ на диске ИТС RequestConsoleManaged\ИнструментыРазработчикаКонсольЗапросов­83.epf
17. premierex 08.04.15 14:25 Сейчас в теме
Не работает с параметром типа "Список значений", выдаёт ошибку "{(1,1)}: Переменная не определена (Прочее)
<<?>>Прочее", где "Прочее" - элемент справочника, заданного в параметре типа "Список значений". Да и сам подбор в список очень уж неудобно организован: тип выбирается из длинного выпадающего меню. Пока до самого низа его прокрутишь, чтобы необходимый тип выбрать, уже и желание пропадает этой консолью пользоваться.
18. unichkin 1259 03.09.15 21:33 Сейчас в теме
19. Kashemir 351 04.09.15 10:53 Сейчас в теме
(18) unichkin, Безусловно - но не всегда космический корабль удобнее автомобиля.
20. user645364_roman_sh 10.06.18 18:05 Сейчас в теме
Вот здесь выполняется запрос ОтладочныйЗапрос, для которого нет никаких параметров кроме параметров типа таблица значений.
Попытка
ОтладочныйЗапрос.Выполнить();
Исключение
ТекстОшибки = ОписаниеОшибки();
Продолжить;
КонецПопытки;

Почему не копируются параметры сразу? Например после строк

ОтладочныйЗапрос.Текст = ТЗ.Текст;
//по идее должны следовать строки
Для Каждого ЭлементСтруктуры Из Зн.Параметры Цикл
ОтладочныйЗапрос.Параметры.Вставить(ЭлементСтруктуры.Ключ, ЭлементСтруктуры.Значение);
КонецЦикла;
22. Kashemir 351 21.06.18 03:55 Сейчас в теме
(20) Параметры так и копируются. Через попытку вытягиваются обращения ко временным таблицам. Альтернативой может служит только полноценный синтаксический анализатор, но даже он не сможет типизировать данные временные таблицы.
По мере получения ошибок при обращениях к данным временным таблицам появляется возможность изнать их имена, после чего можно через * выгрузить их из менеджера со всеми типизациями определенными для них в термах 1С.
21. user645364_roman_sh 10.06.18 18:28 Сейчас в теме
Второе замечание касается случаев когда МенеджерВременныхТаблиц запроса ТЗ содержит временные таблицы со значениями полей Неопределено или Null. Тогда начинает ругаться что при выполнении запроса ОтладочныйЗапрос эти его поля нетипизированные. Здесь может помочь вариант их к-л массово типизировать. Я в этом случае таким полям до использования функции EWG_Сохранить присвоил пустые ссылки в запросе используя Значение(справочник. и т.д...Понимаю некорректно, но по-другому не придумал.
23. Kashemir 351 21.06.18 04:00 Сейчас в теме
24. RailMen 798 11.09.18 19:06 Сейчас в теме
Допилил консольку так: сделал кнопку "Загрузить таблицу из excel". При загрузке из excel автоматом задаются типы колонок.

Прикрепленные файлы:
EWG_Консользапросов (Консоль запросов + ТЗ как параметры 8.2) 2.epf
Оставьте свое сообщение

См. также

"Процессы 3.0: CRM, Бизнес-процессы, Управление по целям". Универсальная система управления процессами и показателями для любой конфигурации 1С Промо

Управление бизнес-процессами (BPM) v8 1cv8.cf УУ Платные (руб)

"Процессы 3.0" - это подсистема для любой конфигурации 1С. Она управляет бизнес-процессами, считает показатели, зарплату сотрудников, создает интерфейсы. "Процессы" состоят из конструкторов, с помощью которых можно создавать бизнес-процессы, скрипты продаж, системы стимулирования, мотивации и многое другое без программирования.

48000 руб.

15.08.2014    54771    34    124    

Загрузка данных интернет банкинга БелВЭБ

Банковские операции Обмен с банком Банковские операции v8::БУ БП2.0 Беларусь БУ Абонемент ($m)

Загружает информацию из файла интернет банка БелВЭБ

1 стартмани

01.08.2018    6545    5    dedkov    2    

Проверка БСО сервисом blank.bisc.by

WEB v8 1cv8.cf Беларусь Абонемент ($m)

Обработка получает данные о наличии бланков строгой отчетности за организацией Республики Беларусь.

1 стартмани

25.07.2018    5499    3    keyn5565`    0    

Восстановление потерянных связей между контрагентами и контактами после обновления УНФ до версии 1.6.15

Обработка справочников v8::УФ УНФ Беларусь Россия Абонемент ($m)

Восстановление связей контрагент-контакт после обновления УНФ.

1 стартмани

05.07.2018    4895    21    lobodaeva    4    

Конфигурация "Управление мини-отелем" Промо

Управление услугами и сервисом Управление взаимоотношениями с клиентами (СRM) Дебиторская и кредиторская задолженность Производство готовой продукции (работ, услуг) Управление взаимоотношениями с клиентами (СRM) Дебиторская и кредиторская задолженность Производство готовой продукции (работ, услуг) v8 Гостиничный бизнес УУ Платные (руб)

Конфигурация для автоматизации учета работы мини-отеля или хостела. Конфигурация максимально проста, что позволяет приступить к работе максимально быстро! Достаточно посмотреть 9-ти минутное видео, в котором показаны основные принципы работы с конфигурацией. Разработана на управляемых формах. Код открыт, при необходимости конфигурацию можно дорабатывать под свои нужды.

7000 руб.

30.09.2015    27449    10    30    

Справка о заработной плате для БП

Бухгалтерские Зарплата Справки Зарплата v8 v8::БУ БП3.0 Беларусь Россия БУ НДФЛ ФОМС, ПФ, ФСС Платные (руб)

Справка о заработной плате для конфигурации Бухгалтерия предприятия, а также аналогов!

2000 руб.

01.07.2018    90641    2    2    

Выгрузка курсов валют с сайта НБ РБ посредством API с графиками колебаний курсов

Универсальные обработки Обработка справочников v8 v8::БУ БП3.0 Беларусь Платные (руб)

Обработка выгрузки курсов валют с сайта НБ РБ посредством API с графиками колебаний курсов

1000 руб.

31.05.2018    8420    0    0    

Расширение для работы КА "Титан-А","Титан-A wi-fi", "Титан-ПЛЮС" с 1С:Предприятие 8

Фискальный регистратор Кассовые операции Кассовые операции v8 1cv8.cf Беларусь Платные (руб)

Расширение предназначено для работы кассового аппарата "Титан-А" ,"Титан-A wi-fi", "Титан-ПЛЮС" и конфигураций: "Управление торговлей для Беларуси" ред. 3.4 "Розница для Беларуси", ред.2.2 "1С:Комплексная автоматизация для Беларуси 2", ред.2.4 "1С:ERP Управление предприятием 2 для Беларуси", версия 2.4

3000 руб.

22.05.2018    18439    26    57    

Комплексная проверка ведения учета в УТ, КА, УПП, ERP, БП, УНФ, Рознице (с расшифровкой до документов) Промо

Анализ учета Управленческие Финансовые Дебиторская и кредиторская задолженность Закрытие периода Кассовые операции Комиссионная торговля Учет ТМЦ Учетная политика Дебиторская и кредиторская задолженность Закрытие периода Кассовые операции Комиссионная торговля Учет ТМЦ Учетная политика v8 КА1 БП2.0 УТ10 Розница УПП1 УНФ ERP2 УТ11 Беларусь Украина Россия Казахстан БУ УУ Платные (руб)

Комплект проверок ведения учета в УТ10, УТ11, КА, УПП, ERP, УНФ, Рознице по остаткам товаров, партиям товаров организаций, состоянию заказов и денежным средствам. Упрощает поиск и исправление ошибок при закрытии месяца. Отчет позволяет сверить данные в связанных регистрах накопления, проверить отрицательные остатки, найти зависшие суммовые остатки с нулевым количеством. По любой непонятной сумме можно выполнить расшифровку, перейти в отчет по движениям документов, по которым эта сумма образовалась и сверить, откуда появилась проблема.

3000 руб.

04.12.2015    103380    457    175    

Клиент ЕРИП

Внешние источники данных v8 1cv8.cf Беларусь Абонемент ($m)

Встроенный в Управление Компанией для Беларуси клиент для выставления требований и загрузки платежей ЕРИП. Упрощает взаимодействие с сервером ЕРИП.

1 стартмани

20.05.2018    5677    5    liurn    0    

Преобразование текста JSON в дерево значений. УФ (8.3)

Инструментарий разработчика v8 v8::УФ 1cv8.cf Беларусь Абонемент ($m)

Последнее время часто начал сталкиваться с форматом  JSON, и возникла необходимость быстро анализировать те или иные данные в этом формате, отбрасывая ненужные, но при больших объёмах данных зачастую было сложно разобраться в структуре. Так что это обработка для тех, кто хочет увидеть JSON в читабельном виде (знаю, похожие обработки есть на Инфостарте, но для моих данных они все вываливались с ошибками). Обработка ни на что не претендует и сделана исключительно в целях сэкономить время для анализа JSON.

1 стартмани

26.04.2018    6872    27    burni4    5    

Обмен с интернет банком БПС-Сбербанк

Банковские операции Обмен с банком Банковские операции v8 v8::БУ 1cv8.cf Беларусь БУ Абонемент ($m)

Представляет собой надстройку над стандартным обменом с клиентом банка Бухгалтерии для Беларуси 2.1, позволяет производить загрузку выписок из системы интернет банк БПС-Сбербанк

1 стартмани

22.04.2018    7844    16    liurn    1    

Программа Дисплей покупателя: второй монитор (Информационное табло). Поддержка видео Промо

Управление торговлей Рабочее место Розничная торговля Розничная торговля Розничная и сетевая торговля (FMCG) Рестораны, кафе и фаст-фуд УУ Платные (руб)

Программа Дисплей покупателя: второй монитор (Информационное табло) предназначена для работы на любых кассах с различным кассовым программным обеспечением. Взаимодействие происходит с помощью текстовых файлов. На одной половине экрана крутятся изображения с вашей рекламой или акциями, на другой половине отображается текущий заказ покупателя. Фоновое изображение и рекламные картинки вы можете использовать свои. Приложение открывается на полный экран, скрывая панель Пуска. Можно запустить его на втором мониторе, подключенном к кассе или на отдельном компьютере, отправляя на него информацию по сети. Также в качестве дисплея удобно использовать планшет на Windows. Появилась возможность прокручивать видео-ролики со звуком во время простоев. Также можно отключить рекламу и выводить текстовую информацию на весь экран. В версии 2.0 появилась возможность отображать картинки товаров и изменять размер дисплея.

5500 руб.

27.11.2014    64243    58    6    

Правила конвертации данных 7.7 - БП 8.3

Перенос данных из 1С7.7 в 1C8.X v8 1cv8.cf Беларусь БУ Абонемент ($m)

Правила конвертации данных при переходе с конфигураций с 7.7 на Бухгалтерию 2.1 (Беларусь)

2 стартмани

21.04.2018    7695    4    brunet    3    

Загрузка справочника БИК банков с сайта Национального банка Республики Беларусь http://www.nbrb.by для конфигураций 1С 7.7 используя AddIn.V7HttpReader с разбором файла ответа в формате JSON

Обработка справочников Банковские операции Банковские операции v7.7 1С7:Бух Беларусь БУ Абонемент ($m)

Обработка для загрузки справочника БИК банков с сайта Национального банка Республики Беларусь. Пример скачивания файла из интернет из 1С 7.7, пример простого разбора файла JSON из 1С 7.7.

1 стартмани

07.04.2018    11080    3    svilsa    2    

Решение проблемы отображения интерфейса Такси на экранах с маленьким разрешением

Работа с интерфейсом v8 v8::УФ Беларусь Бесплатно (free)

Решение возникшей проблемы при переходе с интерфейса 8.2 на интерфейс Такси на экранах с маленьким разрешением.

06.04.2018    12532    0    Drak87    18    

Помощник работы с залежавшимся товаром и неликвидами Промо

Управленческие Оптовая торговля Розничная торговля Учет ТМЦ Рабочее место Оптовая торговля Розничная торговля Учет ТМЦ v8::ОУ УТ10 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика УУ Платные (руб)

Обработка будет полезна всем, кто заинтересован в избавлении от неликвидов и повышении оборачиваемости. Залежавшийся товар может быть найден различными способами (по коэфф. оборачиваемости, сроку с момента поступления). А на полученный список можно назначить скидки, новую цену, ценовую группу и выполнить другие действия. Для 1С: Управление Торговлей 10.3

3000 руб.

22.09.2014    56929    106    76    

Обновление списка отозванных сертификатов. 1С:Бухгалтерия для Беларуси, редакция 2.1

Обработка справочников WEB v8 1cv8.cf Беларусь БУ Абонемент ($m)

Расширение конфигурации для обновления списка отозванных сертификатов Министерства по налогам и сборам Республики Беларусь и Национальныого центра электронных услуг, для Бухгалтерии для Беларуси, редакция 2.1.

1 стартмани

28.02.2018    7595    1    ilya.rudziak    0    

Импорт выписки за день из интернет-банка "Банк Решение" (Трастбанк) Минск в 1С: Бухгалтерия 7.7

Банковские операции Обмен с банком Банковские операции v77::БУ 1С7:Бух Беларусь БУ Абонемент ($m)

Загружает выписку за день из файла экспорта интернет-банка "Банк Решение" (*.txt) в документ "Выписка" конфигурации 1С: Бухгалтерия 7.7 (7.70.170426) с поиском контрагента по УНП.

1 стартмани

02.02.2018    9245    1    silver30    5    

Импорт таможенных деклараций из программы "Декларант-2011" (РБ) для БП 2.0

Универсальные обработки Внешнеэкономическая деятельность (ВЭД) Внешнеэкономическая деятельность (ВЭД) v8::БУ 1cv8.cf Беларусь БУ Абонемент ($m)

Обработка предназначена для импорта данных из системы "Декларант-2001" (ТаможПроектСофт). Также есть возможность создать номенклатуру, документы поступления, документы доп. расходов. Конфигурация тестировалась на конфигурации "Бухгалтерия для Беларуси, редакция 2.1. Локализация для Республики Беларусь: СООО '1С-Минск' (2.1.19.3) ", версия платформы '8.3.10.2650'.

1 стартмани

29.12.2017    12428    0    c1nil    0    

Управление тендерным отделом Промо

Управленческий учет (прочее) v8 Государственные, бюджетные структуры Россия Платные (руб)

Бизнес-решение на платформе 1С: Предприятие для автоматизации тендерного отдела. Программа предназначена для всех участников тендеров, выступающих в качестве поставщика товаров и услуг.

10000 руб.

31.10.2016    33288    2    48    

Загрузка банков в конфигурацию УНФ для Беларуси

Классификаторы Банковские операции Обработка справочников Банковские операции v8 v8::УФ 1cv8.cf Беларусь Абонемент ($m)

Загрузка справочника банков для конфигурации Управление компанией для Беларуси (ранее УНФ). Классификатор обновлен для использования счетов в формате IBAN и SWIFT кодов банков. Тестировалось на версии УНФ для Беларуси 1.6.9.2

1 стартмани

14.11.2017    11527    2    Kim1C    2    

Трекинг посылок через сервис Белпочты

Внешние источники данных v8 v8::УФ 1cv8.cf Беларусь Абонемент ($m)

Обработка для получения информации о посылках из сервиса webservices.belpost.by

1 стартмани

12.11.2017    7356    2    Kuzja_R    0    

Выгрузка ЭСЧФ из Бухгалтерии 3.0 для Беларуси в XML

Обмен через XML Оптовая торговля Производство готовой продукции (работ, услуг) Оптовая торговля Производство готовой продукции (работ, услуг) v8 БП3.0 Беларусь БУ Абонемент ($m)

Обработка позволяет выгружать сформированные в БП 3.0 для Беларуси счета-фактуры в XML, как это делалось раньше в 77. По разным причинам, не всегда получается настроить полноценное взаимодействие с сайтом, поэтому часто требуется выгрузка XML.

1 стартмани

10.10.2017    12105    7    fixin    0    

Конфигурация "Весовая" ред. 3.0 для Платформы 8.3 Промо

Оптовая торговля Производство готовой продукции (работ, услуг) Розничная торговля Учет ОС и НМА Учет ТМЦ Управленческий учет (прочее) v8 Транспорт, автопарки, такси Беларусь Украина Россия Казахстан УУ Платные (руб)

Конфигурация "Весовая" ред. 3.0 для "1С:Предприятие 8.3" - это решение для организации контроля движения грузов через весовую и остатков на складах предприятий, занимающихся: - сельскохозяйственной деятельностью; - тепличных комплексов; - добывающей и горнодобывающей деятельностью; - производителей бетона и асфальта; - дорожно ремонтно-строительных управлений; - торговых организаций; - речных и морских портов осуществляющих перевалку груза; - и организаций, использующих весовую. Конфигурация реализована полностью в интерфейсе "Такси".

3000 руб.

24.03.2015    68857    85    60    

Обработка для загрузки пробитых чеков из кассы Штрих-МPAY-Ф в Бухгалтерию 8.3 (редакция 3.0) из файла PosTransactions.rep

ККМ Кассовые операции Кассовые операции v8 v8::БУ БП3.0 Беларусь Украина Россия БУ Абонемент ($m)

С помощью данной обработки можно загрузить из кассы Штрих-МPAY-Ф пробитые чеки в Бухгалтерию 1С 8.3 (редакция 3.0).

1 стартмани

02.09.2017    13670    4    ariyacom    0    

Как распознать правильного ИТ-специалиста?

О жизни Россия Бесплатно (free)

Одна из самых распространенных проблем в ИТ – нехватка квалифицированных специалистов. С ней сталкиваются абсолютно все. В статье раскрыты технологии и подходы подбора ИТ-специалиста.

29.08.2017    15480    0    KonstantaNN    254    

Экзорцизм программистскими методами

О жизни Бесплатно (free)

Примеры из жизни о том, как инструменты на платформе 1С помогают компании изгонять зло.

24.08.2017    33556    0    1c-intelligence    59    

Adaptersoft : Управление Сбором Данных. Получение сводной отчетности в базе 1С из однотипных файлов Excel Промо

Загрузка и выгрузка в Excel Управление холдингом (CPM) Управление холдингом (CPM) v8 УУ Платные (руб)

Управление Сбором Данных — конфигурация на 1С 8.2 для получения сводной отчетности в базе 1С из однотипных файлов Excel. Отлично подходит для организации оперативного или управленческого учета. Сочетает в себе гибкость ms Excel с защищенностью данных в 1С. Простая, понятная и доступная система в отличие от 1С:Консолидации или 1С:Свод отчетов.

15000 руб.

25.09.2014    20280    2    8    

Печать первичных документов для бухгалтерского учета. (Республика Беларусь)

Печатные формы документов Документооборот и делопроизводство Документооборот и делопроизводство v8 1cv8.cf Беларусь БУ НДС Абонемент ($m)

Конфигурация для печати первичных документов бухгалтерского учета(РБ).( Расходные накладные(ТТН-1, ТН-2(Вертикальные и горизонтальные с приложением)),счет-фактура, доверенность, платежные поручения и требования, реестр платежных требований, а так же объявление на взнос наличными.

1 стартмани

25.07.2017    8529    1    vlalisol    0    

Справочник банков РБ с новыми кодами БИК и обработка загрузки для него в 1С: 8

Обработка справочников Банковские операции Банковские операции v8 1cv8.cf Беларусь БУ Абонемент ($m)

Справочник банков РБ с новыми кодами БИК и старыми МФО. Обработка загрузки для него в 1С 8 Бухгалтерия, УТ, УНФ.

1 стартмани

20.07.2017    12449    27    MOHCTP    2    

Универсальная конвертация счетов в IBAN и обратно (обычная и управляемая форма)

Универсальные обработки Обработка справочников Банковские операции Банковские операции v8 v8::УФ 1cv8.cf Беларусь Абонемент ($m)

На пороге переходный период для внедрения номеров счетов в формате IBAN. Но если вы все пропустили - не беда, переход занимает пару минут! Читай далее, как это сделать...

1 стартмани

01.07.2017    12747    9    Xershi    6    

[ECDO] Отсылка писем из 1С без проблем - одна из лучших разработок! Промо

Email Управление взаимоотношениями с клиентами (СRM) Управление взаимоотношениями с клиентами (СRM) v7.7 1cv7.md Россия Платные (руб)

1600 пользователей - не могут ошибаться! Отсылка писем из среды 1С без использования почтовых агентов и без использования внешних компонент. Не требуется никаких изменений в конфигурации - взял, и пользуйся. Возможно ведение списка адресатов, ведение набора стандартных тем для писем и ведение стандартных текстов писем; поддерживается присоединение файлов к письму и их архивирование.

1000 руб.

08.06.2006    60240    52    241    

Загрузка новых лицевых счетов работников для Бухгалтерии для Беларуси 1.6 и Зарплаты и Управление Персоналом для Беларуси 2.5

Обработка документов Загрузка и выгрузка в Excel Зарплата Зарплата v8 1cv8.cf Беларусь БУ Абонемент ($m)

Из файла «*. xls(xlsx)», содержащего старый и новый лицевые счета, обработка ищет по старому лицевому счету документ "Заявка на открытие счетов" и в соответствующей строке меняет на новый.

1 стартмани

30.06.2017    5147    0    visusby    0    

Перевод банковских счетов в международный формат IBAN

Обработка справочников Банковские операции Банковские операции v77::БУ 1С7:Бух Беларусь Абонемент ($m)

Данная обработка предназначена для перевода старых банковских счетов (13 знаков) в международный формат IBAN (28 знаков) (для 1C:7.7)

2 стартмани

29.06.2017    8015    0    novichok20    0    

Перевод старых счетов в формат IBAN Беларусь для 1С Бухгалтерии 1.6.73.23 и старше

Обработка справочников Банковские операции Банковские операции v8::БУ 1cv8.cf Беларусь БУ Абонемент ($m)

Обработка позволяет выгрузить ваши расчетные счета в специальном формате и при помощи сайта НБРБ преобразовать номера счетов в формат IBAN

1 стартмани

26.06.2017    5542    3    kejsi    5    

Путевые листы для легкового автомобиля Промо

Управленческий учет (прочее) v8 Автомобили, автосервисы Платные (руб)

Заполнение путевого листа и его расчет топлива согласно пройденному маршруту.

1500 руб.

09.06.2014    23061    7    14    

Универсальная конвертация для 1C 7.7 Беларусь: счетов/кодов банка в IBAN/BIC через сервис iban.bisc.by

Обработка справочников Банковские операции Банковские операции v7.7 1cv7.md Беларусь БУ Абонемент ($m)

Обработка создана для упрощения перехода расчётных счетов и кодов банка в Беларуси с 4 июля 2017 г. на международный формат IBAN и BIC.

1 стартмани

21.06.2017    14328    11    1v7    6    

Обработка для пакетной выгрузки и загрузки расчетных счетов в формате IBAN и БИК SWIFT для сервиса "Калькулятор IBAN" НБ РБ"

Обмен с банком Банковские операции Банковские операции v8 1cv8.cf Беларусь БУ Абонемент ($m)

Выгрузка старых и загрузка новых расчетных счетов в формате IBAN и БИК SWIFT с помощью сервиса "Калькулятор IBAN" НБ РБ (http://iban.bisc.by).

1 стартмани

20.06.2017    7049    4    visusby    8    

Получение и загрузка новых номеров расчетных счетов контрагентов в формате IBAN с сайта НБ (Бухгалтерия для Беларуси, редакция 2.1.)

Обработка справочников Банковские операции Банковские операции v8 v8::БУ 1cv8.cf Беларусь БУ Абонемент ($m)

В связи с тем что, в Беларуси с 04.07.2017 года вводится новый формат банковских счетов, необходимо быстро заменить банковские счета контрагентов на новые. По спискам старых счетов получаем новые счета на сайте НБ и загружаем их в базу.

2 стартмани

20.06.2017    8359    7    iliba    3    

Подсистема "Инструменты разработчика" v5.39 Промо

Инструментарий разработчика v8 1cv8.cf Бесплатно (free)

Интегрированный набор инструментов разработчика: - консоль кода - консоль запросов - консоль построителя отчетов - консоль компоновки данных - консоль заданий - конструктор запроса - справочник алгоритмов - исследователь объектов - интерфейсная панель - настройка журнала регистрации - анализ журнала регистрации - настройка техножурнала - анализ техножурнала - подбор и обработка объектов - редактор объекта БД - редактор констант - редактор параметров сеанса - редактор изменений по плану обмена - редактор пользователей - редактор предопределенных - редактор хранилищ настроек - динамический список - поиск дублей и замена ссылок - контекстная подсказка - синтакс-помощник - поиск битых ссылок - поиск ссылок на объект - структура хранения БД - удаление объектов с контролем ссылок - и прочее

23.09.2007    480700    4340    tormozit    2675    

v77. Выгрузка и загрузка расчетных счетов в формате XML для сервиса "Калькулятор IBAN" НБ РБ

Обмен через XML Банковские операции Банковские операции v7.7 1cv7.md Беларусь БУ Абонемент ($m)

Выгрузка старых и загрузка новых расчетных счетов в формате XML во взаимодействии с сервисом "Калькулятор IBAN" НБ РБ (http://iban.bisc.by) Представлены две обработки: 1. IBtoIBAN - выгрузка старых номеров расчетных счетов. 2. IBANtoIB - загрузка новых номеров формата IBAN. Назначение: облегчить труд бухгалтера по изменению номеров счетов в справочниках "Банковские счета" предприятия и "Расчетные счета" контрагентов.

1 стартмани

17.06.2017    13570    2    item    0    

Загрузка расчетных счетов в формате IBAN

Обработка справочников Загрузка и выгрузка в Excel Банковские операции Банковские операции v8::БУ 1cv8.cf Беларусь БУ Абонемент ($m)

Загрузка новых номеров расчетных счетов контрагентов в формате IBAN.

1 стартмани

17.06.2017    8483    3    xzfantom    0    

Проверка счетов IBAN Беларусь

Универсальные обработки Банковские операции Банковские операции v8 1cv8.cf Беларусь БУ Абонемент ($m)

С 04.07.2017 в Беларуси вводится новая нумерация банковских счетов. Обработка поможет расчитать контрольную цифру, и проверить введенный счет на правильность. + Небольшое количество инфы по переходу

1 стартмани

11.05.2017    11196    3    GOshaSaveiko    15    

COM соединения с базами 1С на различных версиях платформы "Без перерегистрации и СМС"

Администрирование данных 1С v8 1cv8.cf Абонемент ($m)

Описание способа подключения к базам 1С с помощью ComConnector, на различных версиях платформы.

1 стартмани

16.04.2017    72518    229    WizaXxX    53    

Такие разные франчайзи, или как мы делаем большие проекты на 1С. Часть первая: ты помнишь, как всё начиналось

Управление проектом Бесплатно (free)

Недавно была написана статья о том, как работает мотивация персонала. Материал получил активный отклик у читателей Инфостарта, на форуме развернулась дискуссия, которая в итоге была достаточно далека от содержимого исходной статьи и свелась к критике самой идеи работы во франчайзи. Чтобы как-то ответить на эту критику, хотелось бы более подробно рассказать о том, что такое современный франчайзи и как он устроен. Но начнем мы с истории этого вида бизнеса, глазами рядового специалиста. Автор статьи Андрей Мироненко.

10.04.2017    30941    0    1СERP    107    

Мотивация персонала в фирмах франчайзи: а она работает?

Управление проектом Бесплатно (free)

Думаем, что практически любого работающего человека интересует вопрос мотивации. Этой проблемой в одинаковой степени озабочены работники и работодатели: как мотивировать людей, сколько платить, как платить, какая часть оплаты должна быть фиксированной, а какая зависеть от результата работы, как это всё повлияет на результаты работы, стоит ли быть строгим и дотошным руководителем или нужно активно делегировать полномочия подчиненным. ВЦ "Раздолье" провело небольшое исследование на тему мотивации и вот его результат. Автор статьи Андрей Мироненко.

03.04.2017    41612    0    1СERP    231    

Груповая загрузка данных о контрагенте с портала nalog.by по УНП

Обработка справочников WEB v8 УТ10 БП1.6 Беларусь Абонемент ($m)

Предназначена для ГРУППОВОЙ (все аналоги, что видел, работают лишь с одним УНП) загрузки информации с сайта gov.nalog.by Цель обработки - определить контрагентов ликвидированных и находящихся в стадии ликвидации для своевременного отражения в бух.учете расходов, понесенным по долгам по данным контрагентам. (Для справки: Должны уйти на убытки в тот же квартал, когда ликвидировали)

2 стартмани

23.03.2017    8892    3    vova196    1    

Загрузка классификатора банков Беларуси (с сайта - национального банка Беларуси)

Банковские операции Классификаторы Банковские операции v8::БУ v8::УФ БП3.0 Беларусь Абонемент ($m)

Обработка, позволяющая загружать новую информацию напрямую с сайта www.nbrb.by - Национального Банка Беларуси.

1 стартмани

04.03.2017    15277    35    dijee    10    

Главная книга по субсчетам c компактной печатью для 1С 8.2 БП 1.6

Бухгалтерские Оборотно-сальдовая ведомость, Анализ счета Оборотно-сальдовая ведомость, Анализ счета v8 БП1.6 Беларусь БУ Абонемент ($m)

Главная книга для 1С 8.2 БП 1.6. Проверена работа в конфигурации "Бухгалтерия для Беларуси. Редакция 1.6."

1 стартмани

04.03.2017    6033    5    dragonga    0    

Консоль сравнения данных (1С 8, 1С 7.7, SQL, CSV, TXT, DBF, XLS, DOC, XML, JSON, табличный документ) (версия 15.2.51)

Универсальные обработки v8 1cv8.cf Беларусь Абонемент ($m)

Обработка Консоль сравнения данных (КСД) предназначена для сравнения данных, полученных из разных источников данных: информационных баз 1С 8, 1С 7.7, баз данных SQL, файлов формата CSV/TXT/DBF/XLS/DOC/XML, строки JSON, вручную заполненного табличного документа. Минимально необходимая версия платформы: 8.3.6.1977.

1 стартмани

13.02.2017    30655    115    sertak    93