Решение проблемы отображения интерфейса Такси на экранах с маленьким разрешением

Публикация № 812164

Разработка - Работа с интерфейсом

26
Решение возникшей проблемы при переходе с интерфейса 8.2 на интерфейс Такси на экранах с маленьким разрешением.

Т.к. база начинала писаться еще до появления интерфейса Такси, все формы были созданы под 8.2. Появилось желание перевести конфигурацию на интерфейс Такси, чтобы визуально она не отличалась от все остальных конфигураций используемых на Предприятия. Казалось бы, ничего сложного. Запретить в конфигураторе старый интерфейс и оставить только Такси. Так было и сделано. Не прошло и получаса с начала рабочего дня, как посыпался шквал звонков от недовольных пользователей ноутбуков, что все окна поплыли. Пришлось все вернуть обратно. Но идея перевести на Такси все равно засела в голове. Было найдено следующее решение.

Анализируем разрешение экрана и, если оно отличается от заданного в меньшую сторону, тогда включаем компактный режим, иначе режим обычный. Т.к. для применения параметров нужен перезапуск. Анализируем, произошла ли смена режимов отображения. Если она произошла, делаем перезапуск платформы. Для пользователя это выглядит как повторное появление окна выбора пользователя для входа в конфигурацию.

Процедура ПередНачаломРаботыСистемы(Отказ)
	
	АдаптацияИнтерфейсаПодРазрешение()
	
КонецПроцедуры


Процедура АдаптацияИнтерфейсаПодРазрешение()
	//
	Экраны = ПолучитьИнформациюЭкрановКлиента();
	ВысотаЭкрана = Экраны[0].Высота;
	ШиринаЭкрана = Экраны[0].Ширина;	
	Если ВысотаЭкрана < 1080 ИЛИ ШиринаЭкрана < 1920 Тогда
		Если КонсулНастройкаИнтерфейса.УстановитьКомпактныйРежим() Тогда
			ЗавершитьРаботуСистемы(Истина); 
			ЗапуститьПриложение(КонсулНастройкаИнтерфейса.ПовторныйЗапускКонфигурации()) 
		КонецЕсли;
	Иначе	
		Если КонсулНастройкаИнтерфейса.УстановитьОбычныйРежим() Тогда
			ЗавершитьРаботуСистемы(Истина); 
			ЗапуститьПриложение(КонсулНастройкаИнтерфейса.ПовторныйЗапускКонфигурации())
		КонецЕсли;
	КонецЕсли;  	
	ОбновитьИнтерфейс();   	
КонецПроцедуры
Функция УстановитьКомпактныйРежим()  Экспорт
	Настройки =  ХранилищеСистемныхНастроек.Загрузить("Общее/НастройкиКлиентскогоПриложения");
	ТекущаяНастройка = Настройки.ВариантМасштабаФормКлиентскогоПриложения; 
    Настройки.ВариантМасштабаФормКлиентскогоПриложения = ВариантМасштабаФормКлиентскогоПриложения.Компактный;    
    ХранилищеСистемныхНастроек.Сохранить("Общее/НастройкиКлиентскогоПриложения",,Настройки);
	Если ТекущаяНастройка <> ВариантМасштабаФормКлиентскогоПриложения.Компактный Тогда
		Возврат Истина;
	КонецЕсли;
	Возврат Ложь;
	
КонецФункции

Функция УстановитьОбычныйРежим()  Экспорт
	Настройки =  ХранилищеСистемныхНастроек.Загрузить("Общее/НастройкиКлиентскогоПриложения");
	ТекущаяНастройка = Настройки.ВариантМасштабаФормКлиентскогоПриложения;
    Настройки.ВариантМасштабаФормКлиентскогоПриложения = ВариантМасштабаФормКлиентскогоПриложения.Обычный;    
    ХранилищеСистемныхНастроек.Сохранить("Общее/НастройкиКлиентскогоПриложения",,Настройки);
	Если ТекущаяНастройка <> ВариантМасштабаФормКлиентскогоПриложения.Обычный Тогда
		Возврат Истина
		КонецЕсли;
	Возврат Ложь;
КонецФункции

Функция ПовторныйЗапускКонфигурации()Экспорт
    СтрокаСоединенияИБ = СтрЗаменить(СтрокаСоединенияИнформационнойБазы(), """", """""");
    ИмяПрограммыЗапуска = КаталогПрограммы() + ?(Прав(КаталогПрограммы(), 1) = "\", "", "\") + "1cv8s.exe";
    ИмяПользователя = ИмяПользователя();
    Если Не ПустаяСтрока(ИмяПользователя) Тогда
        ПользовательИБ = ПользователиИнформационнойБазы.НайтиПоИмени(ИмяПользователя);
        Если ПользовательИБ = Неопределено Тогда
            АутентификацияОС = Ложь;
        Иначе
            АутентификацияОС = ПользовательИБ.АутентификацияОС;
        КонецЕсли;
        Пользователь = "/N""" + ИмяПользователя + """ " + ?(АутентификацияОС, "/WA+", "/WA-");
    Иначе
        Пользователь = "";
    КонецЕсли;
   Возврат( """" + ИмяПрограммыЗапуска + """ " + 
            "ENTERPRISE " + 
            "/IBConnectionString""" + СтрокаСоединенияИБ + """ " + 
            Пользователь +
            "/DisableStartupMessages");

	
КонецФункции

 

26

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. Dream_kz 98 06.04.18 12:36 Сейчас в теме
Вон, лупа с плюсиком (масштабирование) для кого придумана? Хай жмут, да крутят как надо

з.Ы Знаю что только с 8.3.10, но на скринах оно есть
bforce; rpgshnik; Brawler; Alien_job; BigB; Gang031; +6 3 Ответить
2. Drak87 26 06.04.18 12:46 Сейчас в теме
(1) На 15" ноутбуках лупа не выход. Текст становиться не совсем читабельным. Переход на компактный режим более приятен глазу. Хотя лупу тоже пробовали.
3. ildary 06.04.18 13:01 Сейчас в теме
(1) Прошу прощения, но разве результат действия лупы и компактного такси - идентичный?
4. Dream_kz 98 06.04.18 13:11 Сейчас в теме
(3) https://wonderland.v8.1c.ru/blog/bystroe-masshtabirovanie-form/?sphrase_id=33066

Исходить нужно из того, что в компактном режиме масштаб формы равняется примерно 80%.
5. Drak87 26 06.04.18 14:09 Сейчас в теме
(4)Не совсем. в компактном режиме используются стили, шрифты и отступы как в интерфейсе для 8.2. И говорить про 80 процентов наверное не совсем корректно. Тут все таки идет не масштабирование. а смена стиля отображения
6. ildary 06.04.18 14:13 Сейчас в теме
(5) именно это я и имел в виду - что компактный режим - не просто масштабирование, поэтому Ваше решение имеет право на жизнь.
mister_tula; +1 Ответить
7. kauksi 206 06.04.18 16:35 Сейчас в теме
вот бы и в типовых так. А разработчики такси поработали б в 1400х900
mister_tula; Yashazz; +2 Ответить
8. Yashazz 2943 08.04.18 14:14 Сейчас в теме
(7) А разработчикам типовых как купили несколько лет назад здоровенные мониторы, так они и размахнулись. И в результате вплоть до 8.3.10 извольте, господа, мучиться, туда-сюда крутить постоянно прыгающий экран с бессмысленно здоровенными полями, пустыми местами и уезжающими вдаль кнопками. За эту их поделку по прозвищу "такси" вообще надо сразу гнать как профнепригодных к созданию удобных эргономичных дружественных интерфейсов.
jONES1979; DAnry; Vlad_2008; mister_tula; artfa; for-elenak; shard; +7 Ответить
15. the1 402 11.04.18 15:39 Сейчас в теме
(8) Так им и системники наверное обновили на core i9 с 16-ю ядрами, да по 48 Гигов оперативы. А ты жди открытия формы минуту или две =(
9. CheBurator 3404 08.04.18 22:04 Сейчас в теме
в панели разделов отключите вывод картинок, оставьте только тескт - сэкономите еще место
jONES1979; +1 Ответить
10. Online-Ufa 09.04.18 08:07 Сейчас в теме
(9) В панели разделов удобнее наоборот отключить текст, который занимает больше места, и оставить только картинки, тогда свободным остается большее пространство экрана
или научить пользоваться сочетанием горячих клавиш "Ctrl+Shift+Ё", которое позволяет быстро сворачивать/отображать панель разделов
Brawler; ifilll; the1; systemevil; +4 Ответить
16. the1 402 11.04.18 17:17 Сейчас в теме
(10) Подтверждаю
Прикрепленные файлы:
11. paulpit 18 09.04.18 10:04 Сейчас в теме
Если очень Важна оперативность и надежность вводимых данных, то самая большая проблема - это скупердяйство директора.
Диспетчеру всегда надо ставить экран с максимальным разрешением.
12. Drak87 26 10.04.18 15:01 Сейчас в теме
(11)Дело наоборот в слишком большой лояльности директора. Когда работник сам решает хочет он ноутбук или пк с 27 дюймовым и моником. А нам теперь ищи решение т. к. многие взяли себе ноутбуки
13. 7OH 32 11.04.18 09:56 Сейчас в теме
Дайте пользователю кнопку настройки компакт или нет, и объясните как пользоваться кнопкой масштабирования (которая работает только в НЕ компакте).
И пусть сами себе настраивают как хотят.
14. mister_tula 11.04.18 12:07 Сейчас в теме
17. bforce 437 16.04.18 23:26 Сейчас в теме
Формы на такси, обычно, переписывают. Используют закладки, оптимизируют размещение элементов.
Какой смысл переходить на такси, если все размещение элементов остается прежним (как для обычного или управляемого (в виде 8.2) приложения?
18. Drak87 26 17.04.18 10:00 Сейчас в теме
Тут я с вами согласен. И на данный момент все формы меняются. Но вы попробуйте любое типовое решение на такси запустить на маленьком разрешение экрана. Без компактного режима там все поплывёт и работать будет неудобно
Оставьте свое сообщение

См. также

СКД. Шаг 3. Используем макеты для оформления отчета 74

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Работа с интерфейсом

В данной публикации рассмотрим базовый подход к использованию собственных макетов в СКД на примере формирования небольшого отчета.

13.01.2020    2041    aximo    11       

Онлайн-курс "Подготовка к экзамену 1С:Эксперт и 1С:Профессионал по технологическим вопросам" с 7 по 24 апреля 2020 г. Промо

На курсе вы получите практические навыки решения задач производительности 1С, в том числе характерных для высоконагруженных информационных систем (более 1000 пользователей). Подготовка к экзамену – только одна из составляющих курса. 70% слушателей приходят за знаниями, которые позволят расти и зарабатывать, делать сложные задачи на крупных проектах.

16450 рублей

Добавление собственного поля и состояния в настройки доступности по состоянию в 1С:Документооборот 15

Статья Программист Нет файла v8 ДО Бесплатно (free) Практика программирования Работа с интерфейсом

В данной публикации я хочу описать процесс добавления собственного поля и состояния в функционал настройки доступности по состоянию в 1С:Документооборот.

30.12.2019    958    pavelpribytkin96    1       

[СКД] Вывод картинки в результат любого отчета на СКД 104

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Работа с интерфейсом

Если у вас в справочнике Номенклатура (или другом справочнике) заполнена картинка, то ее можно легко вывести для наглядности отчета.

09.12.2019    4360    1    John_d    16       

Перенос данных УТ 10.3 => УТ 11 / КА 2 / ERP 2 (ЕРП 2) (документы, остатки и справочная информация из "1С:Управление торговлей, ред. 10.3" в УТ 11 / КА 2 / ERP 2). Обновлен до УТ 10.3.56.х, УТ 11.4.10.х, КА 2.4.10.х и ERP 2.4.10.х! Промо

Уже более 100 компаний приобрели перенос и выполнили переход на УТ 11 / КА 2 / ERP 2 с помощью нашей разработки! Обработка перехода с УТ 10.3 на УТ 11 / КА 2 / ERP 2 позволяет перенести не только остатки на указанную дату (как типовой перенос), но и все возможные документы за выбранный период. При выходе новых релизов этих программ оперативно выпускаем обновление обработки. Предоставляем техническую поддержку. Можем сделать бесплатный тестовый перенос!

29700 руб.

Лайфхаки 1С. Настройка списков (Часть 3) 18

Статья Бухгалтер Пользователь Нет файла v8 Бесплатно (free) Работа с интерфейсом

Новая порция лайфхаков по работе с интерфейсом 1С. На этот раз разбираем работу со списками - учимся их упорядочивать, сортировать, создавать новые и перемещать старые. Это очень полезное дополнение к уже имеющимся знаниям по интерфейсу 1С.

03.12.2019    3765    VachKirp    13       

В новой платформе пропала кнопка "Печать". Имитируем БСП 18

Статья Программист Нет файла v8 Россия Бесплатно (free) Работа с интерфейсом

"Приятным" сюрпризом для многих пользователей 1С стало то, что при обновлении платформы (начиная с 8.3.15) полностью поменялся интерфейс. Можно долго спорить о целесообразности этого новшества, но самым главным минусом стало то, что пропали стандартные кнопки на панели инструментов. Разработчики предполагают повсеместное использование БСП, но что делать тем, кто давно и успешно использует самописные конфигурации, в которых формирование печатной формы происходит по ТабДок.Показать(), и не желает их "утяжелять"? Добавим общую форму с нужными нам кнопками.

03.12.2019    4132    Vlan    37       

Перенос данных КА 1.1 / УПП 1.3 => БП 3.0 (перенос остатков, документов и справочников из "1С:Комплексная автоматизация 1.1" / УПП 1.3 в "1С:Бухгалтерия 3.0"). Обновлен до версий КА 1.1.115.х, УПП 1.3.130.х! Промо

Разработка позволяет перенести остатки по всем счетам бух.учета в программу "1С:Бухгалтерия предприятия 8", ред. 3.0 на выбранную дату начала ведения учета. Также переносятся документы за период и вся необходимая справочная информация. Правила оперативно обновляю при выходе новых релизов. Рассылка обновлений правил бесплатно в течение 12 месяцев. Есть видеодемонстрация проведения переноса данных. Конфигурации при использовании обмена остаются полностью типовыми. Перенос данных возможен в Бухгалтерию 3.0 версии ПРОФ, КОРП или базовую.

24700 руб.

Управляемые формы. Изменение формы списка или формы объекта без внесения изменений в типовые формы (без использования расширений) 89

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Работа с интерфейсом

Вносим изменения в типовые формы объектов (документы, справочники, журналы, обработки, общие формы). Не снимая с поддержки эти формы. Создаем программно элементы из общего модуля. Для примера рассмотрю добавление колонки "Скрепка" в форму списка документа. Если к документу привязан файл, то в списке в новой колонке должна отображаться "скрепка".

12.11.2019    6029    John_d    23       

ELK. Время изумительных историй! 27

Статья Системный администратор Программист Бизнес-аналитик Руководитель проекта Нет файла v8 1cv8.cf Бесплатно (free) Журнал регистрации Работа с интерфейсом

Всем привет! Сегодня хочу рассказать вам несколько полезных историй про то как нам помог Elastic search в связке с Kibana. Про сам Elastic рассказывать не буду, уже все давным давно описали и до меня. Все обычно говорят что это полезно, это классно. В то же время, очень мало кто рассказывает про практические ситуации: когда и как помог Elastic. Итак, начнем.

31.10.2019    4552    slozhenikin_com    26       

INFOSTART MEETUP Krasnodar. 14 февраля 2020 г. Промо

Краснодар станет первым в 2020 году местом, где пройдет региональная встреча IT-специалистов сообщества Инфостарт. Тема мероприятия - управление и технологии автоматизации учета на платформе "1С: Предприятие". Стоимость участия - 5000 рублей. Цена действительна до 26.12.2019.

Лайфхаки 1С (часть 2) Настройка работы интерфейса такси. Настройка и советы по работе 14

Статья no Нет файла v8 1cv8.cf Россия Бесплатно (free) Работа с интерфейсом

Советы по настройке интерфейса Такси и особенности работы в этой среде.

24.10.2019    4081    VachKirp    7       

Создание асинхронных виджетов 103

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Работа с интерфейсом

Описание нескольких способов создания асинхронных виджетов для 1С:Предприятия. Рассматриваются способы с использованием HTTP-сервисов и фоновых заданий.

16.10.2019    6313    YPermitin    15       

Базовый курс для начинающих 1С-программистов. Пятый поток. Онлайн-курс с 12 февраля по 15 апреля 2020 г. Промо

Данный онлайн-курс является начальной ступенью по изучению базовых принципов программирования в системе “1С:Предприятие” и предназначен для обучения 1С-программированию “с нуля”.

4500/9500 рублей

Формы. Трудности программной работы 79

Статья Программист Нет файла v8 v8::УФ 1cv8.cf Бесплатно (free) Работа с интерфейсом

Рассматриваем основные подводные камни, с которыми приходится сталкиваться при программной работе с формами, а также способы обхода самых частых проблем.

06.10.2019    6419    YPermitin    21       

Лайфхаки 1С (часть 1). Настройки отчетов и печатных форм 1С 41

Статья Программист Пользователь Стажер Нет файла v8 1cv8.cf Россия Бесплатно (free) Работа с интерфейсом

Статья рассчитана на пользователей или программистов, которые только начинают работать с 1С, для максимально быстрого ознакомления с интерфейсом программы. В статье приведены лайфхаки, которые позволят вам быстро и эффективно научиться настраивать отчёты и печатные в среде программных продуктов 1С. Полученные знания значительно упростят взаимодействие с интерфейсом 1С и повысят продуктивность работы оператора.

02.10.2019    7460    VachKirp    9       

Программы для исполнения 488-ФЗ: Маркировка товаров Промо

1 января 2019 года вступил в силу ФЗ от 25.12.2018 № 488-ФЗ о единой информационной системе маркировки товаров с использованием контрольных (идентификационных) знаков, который позволяет проследить движение товара от производителя до конечного потребителя. Инфостарт предлагает подборку программ, связанных с применением 488-ФЗ и маркировкой товаров.

Добавляем виджет "Задачи от меня" в Документооборот 2.1 31

Статья Программист Нет файла v8 v8::Бизнес-процессы ДО Россия Бесплатно (free) Практика программирования Работа с интерфейсом

Небольшая доработка Документооборота 2.1 для возможности добавления виджета "Задачи от меня" в обработку Текущие дела.

25.09.2019    3485    Sergey_Borisovi4    3       

Готовые переносы данных из различных конфигураций 1C Промо

Рекомендуем готовые решения для переноса данных из различных конфигураций 1C. C техподдержкой от разработчиков и гарантией от Инфостарт.

[Механизм интерфейса] Часы 56

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Работа с интерфейсом Практика программирования Разработка

Добавляем цифровые часы на форму, как бонус рассмотрим вариант и с аналоговыми.

26.08.2019    5108    rpgshnik    34       

Произвольная начальная страница через расширение (программно) 42

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Работа с интерфейсом

Установка своей формы произвольному пользователю на начальную страницу.

14.08.2019    4760    nagaitseff    14       

Подборка решений для взаимодействия со ФГИС «Меркурий» Промо

С 1 июля 2019 года все компании, участвующие в обороте товаров животного происхождения, должны перейти на электронную ветеринарную сертификацию (ЭВС) через ФГИС «Меркурий». Инфостарт предлагает подборку программ, связанных с этим изменением.

Подходы, методы и инструменты UX/UI для разработки эффективных интерфейсов на 1С 34

Статья Программист Нет файла v8 Бесплатно (free) Работа с интерфейсом

Интерфейсам в 1С обычно уделяют мало внимания. Это в итоге снижает востребованность платформы, делает ее неконкурентной, лишает большой доли рынка. Как не потерять старых клиентов и привлекать новых с помощью интерфейсов, а главное – как сделать «правильный» интерфейс, рассказал участникам конференции Infostart Event 2018 Education управляющий партнер и основатель консалтинговой группы WiseAdvice Иван Тягунов.

07.08.2019    6407    IvanAT1981    14       

Программы для исполнения 54-ФЗ Промо

С 01.02.2017 контрольно-кассовая техника должна отправлять электронные версии чеков оператору фискальных данных - правила установлены в 54-ФЗ ст.2 п.2. Инфостарт предлагает подборку программ, связанных с применением 54-ФЗ, ККТ и электронных чеков.

Пользовательские настройки системы компоновки данных 91

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования Работа с интерфейсом

Работа с отчетами в пользовательском режиме, формы отчетов. Понятие пользовательских настроек в отчетах на СКД. Определение состава пользовательских настроек для разделов в целом и для отдельных элементов, для всего отчета и для отдельных группировок. Видимость функциональных опций в отчетах на СКД.

09.07.2019    11196    ids79    2       

1C:Предприятие для программистов: Запросы и отчеты. Второй поток. Онлайн-интенсив с 17 марта по 16 апреля 2020 г. Промо

Данный онлайн-курс предусматривает углубленное изучение языка запросов и возможностей системы компоновки данных, которые понадобятся при разработке отчетов, работающих на платформе “1С:Предприятие” в рамках различных прикладных решений. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей различных прикладных решений, которые используют в своей работе отчеты разного назначения.

6500 рублей

Подсистема "Варианты отчетов". Используете ли Вы ее правильно? 230

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Работа с интерфейсом БСП (Библиотека стандартных подсистем)

Небольшая история про использование подсистемы "Варианты отчетов" из БСП. Используете ли Вы ее правильно?

04.06.2019    22902    YPermitin    49       

Расшифровка отчета на СКД с детализацией по выбранному полю на основе БСП 93

Статья Программист Нет файла v8 v8::УФ v8::СКД 1cv8.cf Россия Бесплатно (free) Практика программирования Работа с интерфейсом Разработка

В данной статье рассмотрим механизм работы с расшифровкой отчета, созданного при помощи системы компоновки данных, в управляемом приложении. Показывать буду на примере реальной задачи. Условие: использовать имеющиеся в конфигурации механизмы БСП, с минимальными и "правильными" изменениями. Расшифровка должны быть двух видов на каждом поле: 1. Открывать ссылочный объект 2. Открывать новую форму с детализацией табличной части документа. Собственно ради второго пункта и писалась статья, в основном для себя, чтобы не забыть.

14.05.2019    10851    Viktor_Ermakov    6       

Онлайн-курс «Практические аспекты внедрения регламентированного учета и расчета себестоимости в 1С:ERP на крупных промышленных предприятиях» с 17 февраля по 13 марта 2020 года. Промо

Курс рассчитан для подготовки экспертов по регламентированному учету и учету затрат для внедрения на крупных промышленных предприятиях с «исторически сложившимся» учетом

9000 рублей

Свой макет оформления отчета 35

Статья Программист Нет файла v8 v8::СКД Россия Windows Бесплатно (free) Работа с интерфейсом

Пример создания и оформления и применения своего (пользовательского ) макета оформления для СКД.

24.04.2019    7061    olegpkc    5       

22 января состоится вебинар "Использование технологии блокчейн в 1С" Промо

На вебинаре вы узнаете как использовать современную технологию блокчейн при проектировании и создании учетных систем, почему эту технологию следует рассматривать как одну из базовых. Ведущий Михаил Калимулин поделится своими знаниями основ технологии и опытом внедрения.

990 рублей

Раздельный вывод частей даты на форму без программирования 73

Статья Программист Нет файла v8::УФ 1cv8.cf Бесплатно (free) Работа с интерфейсом

Небольшой лайфхак для повышения удобства редактирования пользователем полей с типом "Дата".

12.01.2019    6766    drmaxart    20       

Динамический вывод таблицы значений на форму 36

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Работа с интерфейсом

Вывести на форму таблицу значений, а потом на её место другую, третью, четвёртую? Не вопрос.

11.01.2019    7628    Vlad1917    30