Загрузка справочника БИК банков с сайта Национального банка Республики Беларусь http://www.nbrb.by для конфигураций 1С 7.7 используя AddIn.V7HttpReader с разбором файла ответа в формате JSON

Публикация № 812617

Учет и отчетность - Банковские операции

Загрузка файла из интернет программно 1С 7.7 HTTPСоединение JSON Классификатор банков РБ

Обработка для загрузки справочника БИК банков с сайта Национального банка Республики Беларусь. Пример скачивания файла из интернет из 1С 7.7, пример простого разбора файла JSON из 1С 7.7.

С 4 июля 2017г. в Республике Беларусь осуществлен переход на международный формат номера банковского счета IBAN (International Bank Account Number) и новые банковские идентификационные коды банков BIC (Bank Identifier Code). На сайте Национального банка Республики Беларусь представлен перечень действующих БИК банков, с описанием АPI по справочнику БИК можно ознакомиться по ссылке: http://www.nbrb.by/apihelp/bic. Файл-ответ с сайта содержит файл в формате JSON.

Обработка получает файл-ответ в формате JSON c сайта (используется внешняя компонента v7plus.dll), разбирает файл JSON и записывает новые банки в справочник банков конфигурации 1С 7.7.

Обработка тестировалось на версиях конфигураций 1С 7.7 Юкола. Бухгалтерский учет. Типовая настройка для РБ; Мисофт. Бухгалтерский учет, редакция 4,5.

//Вспомогательная функция
Функция ПреобразоватьСтрокуИзУТФ8(Стр) 
	Длина = СтрДлина(Стр); 
	Итог = ""; 
	Для Н=1 По Длина Цикл 
		Знак = Сред(Стр, Н, 1); 
		Код = КодСимв(Знак); 
		Если Код < 128 Тогда 
			Итог = Итог + Знак; 
		ИначеЕсли (Код >= 128) И (Код < 192) Тогда 
		Иначе 
			Н = Н + 1; 
			Знак2 = Сред(Стр,Н,1); 
			Код2 = КодСимв(Знак2); 
			Если Код = 208 Тогда 
				Итог=Итог + Симв(КодСимв("А")  +Код2 - 144); 
			ИначеЕсли Код = 209 Тогда 
				Итог=Итог + Симв(КодСимв("р") + Код2 - 128); 
			КонецЕсли; 
		КонецЕсли; 
	КонецЦикла; 
	Возврат Итог; 
КонецФункции 

Процедура Сформировать()
	///**** 1 **** Подключить внешнюю компоненту
	Если ЗагрузитьВнешнююКомпоненту("v7plus.dll") <> 1 Тогда
        Сообщить("Компонента v7plus.dll не найдена!");
        Возврат;
    КонецЕсли;
    ///**** 1 ****
	
	///**** 2 **** Скачать файл из интернета средствами 1С 7.7
    HTTPСоединение=СоздатьОбъект("AddIn.V7HttpReader");
    URL ="http://www.nbrb.by/API/BIC"; 
	//Описание API: http://www.nbrb.by/apihelp/bic
    ИмяФ = КаталогВременныхФайлов() + "bic.txt"; 
    Попытка
        HTTPСоединение.ПолучитьКакФайл(URL, ИмяФ);
    Исключение
        Ответ = HTTPСоединение.СтрокаСостоянияОтвета;
        Сообщить(Ответ);
        Возврат;
    КонецПопытки;
	///**** 2 ****
	 
	///**** 3 **** Разобрать файл JSON программно из 1С 7.7, заполнить ТаблицуЗначений
	//Образец описания банка в формате JSON
	//{"typ":"Банк","CDBank":"ABLTBY22","CDHeadBank":"ABLTBY22","NrBank":"898","BICStatus":"0",
	//"NmBankShort":"ЗАО 'АБСОЛЮТБАНК'","AdrBank":"Г.МИНСК","CdControl":null,"DtControl":null,"CdBankSuccessor":null} 
	ТЗ = СоздатьОбъект("ТаблицаЗначений");
	ТЗ.НоваяКолонка("КодБанка"); 
	ТЗ.НоваяКолонка("НомерБанка");
	ТЗ.НоваяКолонка("НазваниеБанка");
	ТЗ.НоваяКолонка("АдресБанка");
	Файл = СоздатьОбъект("Текст");
	Файл.Открыть(ИмяФ);
	Файл.КодоваяСтраница(1);
	Для инд = 1 По Файл.КоличествоСтрок() Цикл
		Стр = Файл.ПолучитьСтроку(инд); 
		Стр = ПреобразоватьСтрокуИзУТФ8(Стр);
		НачалоБанка = Найти(Стр, "{");
		Пока НачалоБанка > 0 Цикл 
			КонецБанка = Найти(Стр, "}");
			СтрокаБанка = Сред(Стр, НачалоБанка, КонецБанка - НачалоБанка + 1);
			Стр = СтрЗаменить(Стр, СтрокаБанка, "");
			НачалоБанка = Найти(Стр, "{");
			
			ТЗ.НоваяСтрока();
			
			Нач = Найти(СтрокаБанка, "CDBank");
			Кон = Найти(СтрокаБанка, "CDHeadBank");
			ТЗ.КодБанка = Сред(СтрокаБанка, Нач + 9, Кон - Нач - 12);  
			
			Нач = Найти(СтрокаБанка, "NrBank");
			Кон = Найти(СтрокаБанка, "BICStatus");
			ТЗ.НомерБанка = Сред(СтрокаБанка, Нач + 9, Кон - Нач - 12);
			
			Нач = Найти(СтрокаБанка, "NmBankShort");
			Кон = Найти(СтрокаБанка, "AdrBank");
			ТЗ.НазваниеБанка = Сред(СтрокаБанка, Нач + 14, Кон - Нач - 17);
			
			Нач = Найти(СтрокаБанка, "AdrBank");
			Кон = Найти(СтрокаБанка, "CdControl");
			ТЗ.АдресБанка = Сред(СтрокаБанка, Нач + 10, Кон - Нач - 13);
			
		КонецЦикла;
	КонецЦикла;
	///**** 3 ****
	
	///**** 4 **** Записать новые банки Республики Беларусь в справочник банков 1С 7.7 (МИСОФТ/ЮКОЛА)
	Банки = СоздатьОбъект("Справочник.Банки");
	ТЗ.ВыбратьСтроки();
	Пока ТЗ.ПолучитьСтроку() = 1 Цикл
		Если Банки.НайтиПоКоду(ТЗ.КодБанка) <> 0 Тогда
			Продолжить; //Банк уже существует в справочнике
		КонецЕсли;                                         
		Банки.Новый();
		Банки.Код = ТЗ.КодБанка;
		Банки.Наименование = ТЗ.НазваниеБанка;
		Банки.Адрес = ТЗ.АдресБанка;
		Банки.Записать();
		Сообщить("Загружен банк " + Тз.НазваниеБанка + " " + ТЗ.КодБанка);
	КонецЦикла;
	///**** 4 ****

	ФС.УдалитьФайл(ИмяФ);

КонецПроцедуры

Скачать файлы

Наименование Файл Версия Размер
Загрузка справочника БИК банков с сайта Нацонального банка Республики Беларусь http://www.nbrb.by для конфигураций 1С 7.7 используя AddIn.V7HttpReader с разбором файла ответа в формате JSON:

.ert 42,50Kb
07.04.18
3
.ert 42,50Kb 3 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. Dnki 4 03.09.18 00:57 Сейчас в теме
Благодарю за идею - не знал про API сайта.
Скачиваю в знак благодарности.
Как замечание могу только сказать: из всего списка банков есть несколько со статусом "Закрыт", "Ликвидирован". Вы их обрабатываете как нормальные банки.
2. Dnki 4 03.09.18 01:11 Сейчас в теме
А здорово, когда есть в распоряжении инструменты! Набросал аналог на 8-ке:
Функция Загрузить()
	
	//	Запрос
	Соединение = Новый HTTPСоединение("www.nbrb.by");
	Попытка
	АшТТП_Ответ		= Соединение.Получить(Новый HTTPЗапрос("/API/BIC"));
	Исключение
		Сообщить(ОписаниеОшибки());
		Возврат Ложь;
	КонецПопытки;
	
	ЧтениеJSON = Новый ЧтениеJSON;
	ЧтениеJSON.УстановитьСтроку(АшТТП_Ответ.ПолучитьТелоКакСтроку());
	Т_Массив = ПрочитатьJSON(ЧтениеJSON, Ложь);
	
	//	Разбор
	КолНов = 0;
	КолУдл = 0;
	СпрМен = Справочники.Банки;
	Для каждого ТекЭлемент Из Т_Массив Цикл
		Т_Статус= ТекЭлемент.CdControl;
		Т_Удл	= (СтрНайти("ЛИКВ,ЗАКР", Т_Статус) > 0);
		Т_БИК	= ТекЭлемент.CdBank;
		
		//	Поиск
		СпрСылка = СпрМен.НайтиПоКоду(Т_БИК);
		
		//	Есть
		Если ЗначениеЗаполнено(СпрСылка) Тогда
			Если Т_Удл И НЕ СпрСылка.ПометкаУдаления Тогда
				СпрОбъект = СпрСылка.ПолучитьОбъект();
				СпрОбъект.УстановитьПометкуУдаления(Истина);
				Увеличить(КолУдл);
			КонецЕсли;

		//	Нету
		Иначе
			Если НЕ Т_Удл Тогда
				СпрОбъект = СпрМен.СоздатьЭлемент();
				СпрОбъект.Код			= Т_БИК;
				СпрОбъект.Наименование	= ТекЭлемент.NmBankShort;
				СпрОбъект.Адрес			= ТекЭлемент.AdrBank;
				Попытка
				СпрОбъект.Записать();
				Исключение
					Сообщить(ОписаниеОшибки());
				КонецПопытки;
				Увеличить(КолНов);
			КонецЕсли;
		КонецЕсли;	// ЗначениеЗаполнено(СпрСылка)
	КонецЦикла;	// Т_Массив

	Предупреждение("Новых: "+ КолНов+ Символы.ПС+ "Удалено: "+ КолУдл, 10);
	Возврат Истина;
КонецФункции	// Загрузить
Показать
1v7; svilsa; +2 Ответить
Оставьте свое сообщение

См. также

Расширение для работы КА "Титан-А","Титан-A wi-fi", "Титан-ПЛЮС" с 1С:Предприятие 8 Промо

Фискальный регистратор Кассовые операции Кассовые операции v8 1cv8.cf Беларусь Платные (руб)

Расширение предназначено для работы кассового аппарата "Титан-А" ,"Титан-A wi-fi", "Титан-ПЛЮС" и конфигураций: "Управление торговлей для Беларуси" ред. 3.4 "Розница для Беларуси", ред.2.2 "1С:Комплексная автоматизация для Беларуси 2", ред.2.4 "1С:ERP Управление предприятием 2 для Беларуси", версия 2.4

3000 руб.

22.05.2018    20757    28    62    

Загрузка данных интернет банкинга БелВЭБ

Банковские операции Обмен с банком Банковские операции v8::БУ БП2.0 Беларусь БУ Абонемент ($m)

Загружает информацию из файла интернет банка БелВЭБ

1 стартмани

01.08.2018    7444    5    dedkov    2    

Проверка БСО сервисом blank.bisc.by

WEB v8 1cv8.cf Беларусь Абонемент ($m)

Обработка получает данные о наличии бланков строгой отчетности за организацией Республики Беларусь.

1 стартмани

25.07.2018    6108    3    keyn5565`    0    

Восстановление потерянных связей между контрагентами и контактами после обновления УНФ до версии 1.6.15

Обработка справочников v8::УФ УНФ Беларусь Россия Абонемент ($m)

Восстановление связей контрагент-контакт после обновления УНФ.

1 стартмани

05.07.2018    5270    21    lobodaeva    4    

Комплексная проверка ведения учета в УТ, КА, УПП, ERP, БП, УНФ, Рознице (с расшифровкой до документов) Промо

Анализ учета Управленческие Финансовые Дебиторская и кредиторская задолженность Закрытие периода Кассовые операции Комиссионная торговля Учет ТМЦ Учетная политика Дебиторская и кредиторская задолженность Закрытие периода Кассовые операции Комиссионная торговля Учет ТМЦ Учетная политика v8 КА1 БП2.0 УТ10 Розница УПП1 УНФ ERP2 УТ11 Беларусь Украина Россия Казахстан БУ УУ Платные (руб)

Комплект проверок ведения учета в УТ10, УТ11, КА, УПП, ERP, УНФ, Рознице по остаткам товаров, партиям товаров организаций, состоянию заказов и денежным средствам. Упрощает поиск и исправление ошибок при закрытии месяца. Отчет позволяет сверить данные в связанных регистрах накопления, проверить отрицательные остатки, найти зависшие суммовые остатки с нулевым количеством. По любой непонятной сумме можно выполнить расшифровку, перейти в отчет по движениям документов, по которым эта сумма образовалась и сверить, откуда появилась проблема.

3000 руб.

04.12.2015    108892    481    178    

Справка о заработной плате для БП

Бухгалтерские Зарплата Справки Зарплата v8 v8::БУ БП3.0 Беларусь Россия БУ НДФЛ ФОМС, ПФ, ФСС Платные (руб)

Справка о заработной плате для конфигурации Бухгалтерия предприятия, а также аналогов!

2000 руб.

01.07.2018    95800    2    2    

Выгрузка курсов валют с сайта НБ РБ посредством API с графиками колебаний курсов

Универсальные обработки Обработка справочников v8 v8::БУ БП3.0 Беларусь Платные (руб)

Обработка выгрузки курсов валют с сайта НБ РБ посредством API с графиками колебаний курсов

1000 руб.

31.05.2018    9863    0    0    

Клиент ЕРИП

Внешние источники данных v8 1cv8.cf Беларусь Абонемент ($m)

Встроенный в Управление Компанией для Беларуси клиент для выставления требований и загрузки платежей ЕРИП. Упрощает взаимодействие с сервером ЕРИП.

1 стартмани

20.05.2018    6248    5    liurn    0    

Автоматизация администрирования информационных баз (версия 6.3) Промо

Администрирование данных 1С Архивирование (backup) v8 Платные (руб)

Конфигурация на платформе 1С 8.2/8.3, позволяющая упростить работу по ведению реестра большого количества баз 1С, а также автоматизировать процесс выгрузки/загрузки данных, ТИИ, установки и загрузки обновлений, управление учетными записями пользователей, публикацию интернет-сервиса списков информационных баз, групповые операции над несколькими базами в том числе с использованием регламентных заданий.

2000 руб.

05.07.2013    94012    207    376    

Преобразование текста JSON в дерево значений. УФ (8.3)

Инструментарий разработчика v8 v8::УФ 1cv8.cf Беларусь Абонемент ($m)

Последнее время часто начал сталкиваться с форматом  JSON, и возникла необходимость быстро анализировать те или иные данные в этом формате, отбрасывая ненужные, но при больших объёмах данных зачастую было сложно разобраться в структуре. Так что это обработка для тех, кто хочет увидеть JSON в читабельном виде (знаю, похожие обработки есть на Инфостарте, но для моих данных они все вываливались с ошибками). Обработка ни на что не претендует и сделана исключительно в целях сэкономить время для анализа JSON.

1 стартмани

26.04.2018    7780    29    burni4    5    

Обмен с интернет банком БПС-Сбербанк

Банковские операции Обмен с банком Банковские операции v8 v8::БУ 1cv8.cf Беларусь БУ Абонемент ($m)

Представляет собой надстройку над стандартным обменом с клиентом банка Бухгалтерии для Беларуси 2.1, позволяет производить загрузку выписок из системы интернет банк БПС-Сбербанк

1 стартмани

22.04.2018    9784    16    liurn    1    

Правила конвертации данных 7.7 - БП 8.3

Перенос данных из 1С7.7 в 1C8.X v8 1cv8.cf Беларусь БУ Абонемент ($m)

Правила конвертации данных при переходе с конфигураций с 7.7 на Бухгалтерию 2.1 (Беларусь)

2 стартмани

21.04.2018    8335    4    brunet    3    

Помощник работы с залежавшимся товаром и неликвидами Промо

Управленческие Оптовая торговля Розничная торговля Учет ТМЦ Рабочее место Оптовая торговля Розничная торговля Учет ТМЦ v8::ОУ УТ10 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика УУ Платные (руб)

Обработка будет полезна всем, кто заинтересован в избавлении от неликвидов и повышении оборачиваемости. Залежавшийся товар может быть найден различными способами (по коэфф. оборачиваемости, сроку с момента поступления). А на полученный список можно назначить скидки, новую цену, ценовую группу и выполнить другие действия. Для 1С: Управление Торговлей 10.3

3000 руб.

22.09.2014    59081    109    76    

Загрузка справочника БИК банков с сайта Национального банка Республики Беларусь http://www.nbrb.by для конфигураций 1С 7.7 используя AddIn.V7HttpReader с разбором файла ответа в формате JSON

Обработка справочников Банковские операции Банковские операции v7.7 1С7:Бух Беларусь БУ Абонемент ($m)

Обработка для загрузки справочника БИК банков с сайта Национального банка Республики Беларусь. Пример скачивания файла из интернет из 1С 7.7, пример простого разбора файла JSON из 1С 7.7.

1 стартмани

07.04.2018    13244    3    svilsa    2    

Решение проблемы отображения интерфейса Такси на экранах с маленьким разрешением

Работа с интерфейсом v8 v8::УФ Беларусь Бесплатно (free)

Решение возникшей проблемы при переходе с интерфейса 8.2 на интерфейс Такси на экранах с маленьким разрешением.

06.04.2018    13143    Drak87    18    

Обновление списка отозванных сертификатов. 1С:Бухгалтерия для Беларуси, редакция 2.1

Обработка справочников WEB v8 1cv8.cf Беларусь БУ Абонемент ($m)

Расширение конфигурации для обновления списка отозванных сертификатов Министерства по налогам и сборам Республики Беларусь и Национальныого центра электронных услуг, для Бухгалтерии для Беларуси, редакция 2.1.

1 стартмани

28.02.2018    8205    1    ilya.rudziak    0    

Справочник кодов ТНВЭД Промо

Обработка справочников WEB Внешнеэкономическая деятельность (ВЭД) Учет ТМЦ Внешнеэкономическая деятельность (ВЭД) Учет ТМЦ v8 КА1 БП2.0 УТ10 Розница УПП1 Платные (руб)

Загрузка справочника ТНВЭД в базу данных 1С без изменения конфигурации. База кодов загружается с сайта www.nalog.ru или локального ресурса. После загрузки - справочник всегда под рукой! Реализован поиск по загруженной базе. Доступны примечания для групп справочника (комментарии налогового органа). Дополнительно реализовано занесение кодов ТНВЭД в справочники ИБ (например, справочник Номенклатура) как реквизита или свойства справочника. Подходит для всех стандартных конфигураций (БП, УПП, КА, УТ, Розница и пр.).

3100 руб.

29.09.2015    36856    17    0    

Импорт выписки за день из интернет-банка "Банк Решение" (Трастбанк) Минск в 1С: Бухгалтерия 7.7

Банковские операции Обмен с банком Банковские операции v77::БУ 1С7:Бух Беларусь БУ Абонемент ($m)

Загружает выписку за день из файла экспорта интернет-банка "Банк Решение" (*.txt) в документ "Выписка" конфигурации 1С: Бухгалтерия 7.7 (7.70.170426) с поиском контрагента по УНП.

1 стартмани

02.02.2018    10584    1    silver30    5    

Импорт таможенных деклараций из программы "Декларант-2011" (РБ) для БП 2.0

Универсальные обработки Внешнеэкономическая деятельность (ВЭД) Внешнеэкономическая деятельность (ВЭД) v8::БУ 1cv8.cf Беларусь БУ Абонемент ($m)

Обработка предназначена для импорта данных из системы "Декларант-2001" (ТаможПроектСофт). Также есть возможность создать номенклатуру, документы поступления, документы доп. расходов. Конфигурация тестировалась на конфигурации "Бухгалтерия для Беларуси, редакция 2.1. Локализация для Республики Беларусь: СООО '1С-Минск' (2.1.19.3) ", версия платформы '8.3.10.2650'.

1 стартмани

29.12.2017    13854    3    c1nil    0    

Загрузка банков в конфигурацию УНФ для Беларуси

Классификаторы Банковские операции Обработка справочников Банковские операции v8 v8::УФ 1cv8.cf Беларусь Абонемент ($m)

Загрузка справочника банков для конфигурации Управление компанией для Беларуси (ранее УНФ). Классификатор обновлен для использования счетов в формате IBAN и SWIFT кодов банков. Тестировалось на версии УНФ для Беларуси 1.6.9.2

1 стартмани

14.11.2017    12552    3    Kim1C    2    

Конфигурация "Весовая" ред. 3.0 для Платформы 8.3 Промо

Оптовая торговля Производство готовой продукции (работ, услуг) Розничная торговля Учет ОС и НМА Учет ТМЦ Оптовая торговля Производство готовой продукции (работ, услуг) Розничная торговля Учет ОС и НМА Учет ТМЦ v8 Транспорт, автопарки, такси Беларусь Украина Россия Казахстан УУ Платные (руб)

Конфигурация "Весовая" ред. 3.0 для "1С:Предприятие 8.3" - это решение для организации контроля движения грузов через весовую и остатков на складах предприятий, занимающихся: - сельскохозяйственной деятельностью; - тепличных комплексов; - добывающей и горнодобывающей деятельностью; - производителей бетона и асфальта; - дорожно ремонтно-строительных управлений; - торговых организаций; - речных и морских портов осуществляющих перевалку груза; - и организаций, использующих весовую. Конфигурация реализована полностью в интерфейсе "Такси".

3000 руб.

24.03.2015    74367    98    69    

Выгрузка ЭСЧФ из Бухгалтерии 3.0 для Беларуси в XML

Обмен через XML Оптовая торговля Производство готовой продукции (работ, услуг) Оптовая торговля Производство готовой продукции (работ, услуг) v8 БП3.0 Беларусь БУ Абонемент ($m)

Обработка позволяет выгружать сформированные в БП 3.0 для Беларуси счета-фактуры в XML, как это делалось раньше в 77. По разным причинам, не всегда получается настроить полноценное взаимодействие с сайтом, поэтому часто требуется выгрузка XML.

1 стартмани

10.10.2017    12721    7    fixin    0    

Обработка для загрузки пробитых чеков из кассы Штрих-МPAY-Ф в Бухгалтерию 8.3 (редакция 3.0) из файла PosTransactions.rep

ККМ Кассовые операции Кассовые операции v8 v8::БУ БП3.0 Беларусь Украина Россия БУ Абонемент ($m)

С помощью данной обработки можно загрузить из кассы Штрих-МPAY-Ф пробитые чеки в Бухгалтерию 1С 8.3 (редакция 3.0).

1 стартмани

02.09.2017    14274    5    ariyacom    0    

Как распознать правильного ИТ-специалиста?

О жизни Россия Бесплатно (free)

Одна из самых распространенных проблем в ИТ – нехватка квалифицированных специалистов. С ней сталкиваются абсолютно все. В статье раскрыты технологии и подходы подбора ИТ-специалиста.

29.08.2017    15988    KonstantaNN    254    

Программа Дисплей покупателя: второй монитор (Информационное табло). Поддержка видео Промо

Управление торговлей Рабочее место Розничная торговля Розничная торговля Розничная и сетевая торговля (FMCG) Рестораны, кафе и фаст-фуд УУ Платные (руб)

Программа Дисплей покупателя: второй монитор (Информационное табло) предназначена для работы на любых кассах с различным кассовым программным обеспечением. Взаимодействие происходит с помощью текстовых файлов. На одной половине экрана крутятся изображения с вашей рекламой или акциями, на другой половине отображается текущий заказ покупателя. Фоновое изображение и рекламные картинки вы можете использовать свои. Приложение открывается на полный экран, скрывая панель Пуска. Можно запустить его на втором мониторе, подключенном к кассе или на отдельном компьютере, отправляя на него информацию по сети. Также в качестве дисплея удобно использовать планшет на Windows. Появилась возможность прокручивать видео-ролики со звуком во время простоев. Также можно отключить рекламу и выводить текстовую информацию на весь экран. В версии 2.0 появилась возможность отображать картинки товаров и изменять размер дисплея.

5500 руб.

27.11.2014    67603    61    9    

Экзорцизм программистскими методами

О жизни Бесплатно (free)

Примеры из жизни о том, как инструменты на платформе 1С помогают компании изгонять зло.

24.08.2017    34473    1c-intelligence    59    

Печать первичных документов для бухгалтерского учета. (Республика Беларусь)

Печатные формы документов Документооборот и делопроизводство Документооборот и делопроизводство v8 1cv8.cf Беларусь БУ НДС Абонемент ($m)

Конфигурация для печати первичных документов бухгалтерского учета(РБ).( Расходные накладные(ТТН-1, ТН-2(Вертикальные и горизонтальные с приложением)),счет-фактура, доверенность, платежные поручения и требования, реестр платежных требований, а так же объявление на взнос наличными.

1 стартмани

25.07.2017    9114    1    vlalisol    0    

Справочник банков РБ с новыми кодами БИК и обработка загрузки для него в 1С: 8

Обработка справочников Банковские операции Банковские операции v8 1cv8.cf Беларусь БУ Абонемент ($m)

Справочник банков РБ с новыми кодами БИК и старыми МФО. Обработка загрузки для него в 1С 8 Бухгалтерия, УТ, УНФ.

1 стартмани

20.07.2017    13082    27    MOHCTP    2    

"Процессы 3.0: CRM, Бизнес-процессы, Управление по целям". Универсальная система управления процессами и показателями для любой конфигурации 1С Промо

Управление бизнес-процессами (BPM) v8 1cv8.cf УУ Платные (руб)

"Процессы 3.0" - это подсистема для любой конфигурации 1С. Она управляет бизнес-процессами, считает показатели, зарплату сотрудников, создает интерфейсы. "Процессы" состоят из конструкторов, с помощью которых можно создавать бизнес-процессы, скрипты продаж, системы стимулирования, мотивации и многое другое без программирования.

48000 руб.

15.08.2014    59595    37    124    

Универсальная конвертация счетов в IBAN и обратно (обычная и управляемая форма)

Универсальные обработки Обработка справочников Банковские операции Банковские операции v8 v8::УФ 1cv8.cf Беларусь Абонемент ($m)

На пороге переходный период для внедрения номеров счетов в формате IBAN. Но если вы все пропустили - не беда, переход занимает пару минут! Читай далее, как это сделать...

1 стартмани

01.07.2017    13894    9    Xershi    6    

Загрузка новых лицевых счетов работников для Бухгалтерии для Беларуси 1.6 и Зарплаты и Управление Персоналом для Беларуси 2.5

Обработка документов Загрузка и выгрузка в Excel Зарплата Зарплата v8 1cv8.cf Беларусь БУ Абонемент ($m)

Из файла «*. xls(xlsx)», содержащего старый и новый лицевые счета, обработка ищет по старому лицевому счету документ "Заявка на открытие счетов" и в соответствующей строке меняет на новый.

1 стартмани

30.06.2017    5396    0    visusby    0    

Перевод банковских счетов в международный формат IBAN

Обработка справочников Банковские операции Банковские операции v77::БУ 1С7:Бух Беларусь Абонемент ($m)

Данная обработка предназначена для перевода старых банковских счетов (13 знаков) в международный формат IBAN (28 знаков) (для 1C:7.7)

2 стартмани

29.06.2017    9095    0    novichok20    0    

1С:Управление сервисным центром Промо

Управление услугами и сервисом v8 Бытовые услуги, сервис Россия УУ Платные (руб)

Использование конфигурации "1С:Предприятие 8. Управление сервисным центром" позволит решить основные задачи по учету и управлению работой сервисного центра. В основу положена конфигурация Управление небольшой фирмой, так же продукт содержит все возможности и механизмы, реализуемые типовым решением. Использование приложения позволит управлять информационной системой для оказания услуг по гарантийному ремонту, обслуживанию бытовой и компьютерной техники, а так же различного оборудования. Программа "1С:Предприятие 8. Управление сервисным центром" предоставляет пользователям ключевые возможности: проведение анализа, планирования и гибкого управления ресурсами компании; оптимизации эффективности ежедневной работы во всех направлениях; проведение технического обслуживания наличного оборудования; предоставление услуг гарантийного и негарантийного ремонта; обслуживание компьютерной и бытовой техники.

26400 руб.

17.02.2016    25799    2    10    

Перевод старых счетов в формат IBAN Беларусь для 1С Бухгалтерии 1.6.73.23 и старше

Обработка справочников Банковские операции Банковские операции v8::БУ 1cv8.cf Беларусь БУ Абонемент ($m)

Обработка позволяет выгрузить ваши расчетные счета в специальном формате и при помощи сайта НБРБ преобразовать номера счетов в формат IBAN

1 стартмани

26.06.2017    5848    3    kejsi    5    

Универсальная конвертация для 1C 7.7 Беларусь: счетов/кодов банка в IBAN/BIC через сервис iban.bisc.by

Обработка справочников Банковские операции Банковские операции v7.7 1cv7.md Беларусь БУ Абонемент ($m)

Обработка создана для упрощения перехода расчётных счетов и кодов банка в Беларуси с 4 июля 2017 г. на международный формат IBAN и BIC.

1 стартмани

21.06.2017    15649    11    1v7    6    

Обработка для пакетной выгрузки и загрузки расчетных счетов в формате IBAN и БИК SWIFT для сервиса "Калькулятор IBAN" НБ РБ"

Обмен с банком Банковские операции Банковские операции v8 1cv8.cf Беларусь БУ Абонемент ($m)

Выгрузка старых и загрузка новых расчетных счетов в формате IBAN и БИК SWIFT с помощью сервиса "Калькулятор IBAN" НБ РБ (http://iban.bisc.by).

1 стартмани

20.06.2017    7318    4    visusby    8    

Управление тендерным отделом Промо

Управленческий учет (прочее) v8 Государственные, бюджетные структуры Россия Платные (руб)

Бизнес-решение на платформе 1С: Предприятие для автоматизации тендерного отдела. Программа предназначена для всех участников тендеров, выступающих в качестве поставщика товаров и услуг.

10000 руб.

31.10.2016    37607    3    60    

Получение и загрузка новых номеров расчетных счетов контрагентов в формате IBAN с сайта НБ (Бухгалтерия для Беларуси, редакция 2.1.)

Обработка справочников Банковские операции Банковские операции v8 v8::БУ 1cv8.cf Беларусь БУ Абонемент ($m)

В связи с тем что, в Беларуси с 04.07.2017 года вводится новый формат банковских счетов, необходимо быстро заменить банковские счета контрагентов на новые. По спискам старых счетов получаем новые счета на сайте НБ и загружаем их в базу.

2 стартмани

20.06.2017    8971    7    iliba    3    

v77. Выгрузка и загрузка расчетных счетов в формате XML для сервиса "Калькулятор IBAN" НБ РБ

Обмен через XML Банковские операции Банковские операции v7.7 1cv7.md Беларусь БУ Абонемент ($m)

Выгрузка старых и загрузка новых расчетных счетов в формате XML во взаимодействии с сервисом "Калькулятор IBAN" НБ РБ (http://iban.bisc.by) Представлены две обработки: 1. IBtoIBAN - выгрузка старых номеров расчетных счетов. 2. IBANtoIB - загрузка новых номеров формата IBAN. Назначение: облегчить труд бухгалтера по изменению номеров счетов в справочниках "Банковские счета" предприятия и "Расчетные счета" контрагентов.

1 стартмани

17.06.2017    14944    3    item    0    

Загрузка расчетных счетов в формате IBAN

Обработка справочников Загрузка и выгрузка в Excel Банковские операции Банковские операции v8::БУ 1cv8.cf Беларусь БУ Абонемент ($m)

Загрузка новых номеров расчетных счетов контрагентов в формате IBAN.

1 стартмани

17.06.2017    9043    3    xzfantom    0    

Конфигурация "Управление мини-отелем" Промо

Управление услугами и сервисом Управление взаимоотношениями с клиентами (СRM) Дебиторская и кредиторская задолженность Производство готовой продукции (работ, услуг) Управление взаимоотношениями с клиентами (СRM) Дебиторская и кредиторская задолженность Производство готовой продукции (работ, услуг) v8 Гостиничный бизнес УУ Платные (руб)

Конфигурация для автоматизации учета работы мини-отеля или хостела. Конфигурация максимально проста, что позволяет приступить к работе максимально быстро! Достаточно посмотреть 9-ти минутное видео, в котором показаны основные принципы работы с конфигурацией. Разработана на управляемых формах. Код открыт, при необходимости конфигурацию можно дорабатывать под свои нужды.

7000 руб.

30.09.2015    29415    10    32    

Проверка счетов IBAN Беларусь

Универсальные обработки Банковские операции Банковские операции v8 1cv8.cf Беларусь БУ Абонемент ($m)

С 04.07.2017 в Беларуси вводится новая нумерация банковских счетов. Обработка поможет расчитать контрольную цифру, и проверить введенный счет на правильность. + Небольшое количество инфы по переходу

1 стартмани

11.05.2017    12281    3    GOshaSaveiko    15    

COM соединения с базами 1С на различных версиях платформы "Без перерегистрации и СМС"

Администрирование данных 1С v8 1cv8.cf Абонемент ($m)

Описание способа подключения к базам 1С с помощью ComConnector, на различных версиях платформы.

1 стартмани

16.04.2017    81882    251    WizaXxX    55    

Такие разные франчайзи, или как мы делаем большие проекты на 1С. Часть первая: ты помнишь, как всё начиналось

Управление проектом Бесплатно (free)

Недавно была написана статья о том, как работает мотивация персонала. Материал получил активный отклик у читателей Инфостарта, на форуме развернулась дискуссия, которая в итоге была достаточно далека от содержимого исходной статьи и свелась к критике самой идеи работы во франчайзи. Чтобы как-то ответить на эту критику, хотелось бы более подробно рассказать о том, что такое современный франчайзи и как он устроен. Но начнем мы с истории этого вида бизнеса, глазами рядового специалиста. Автор статьи Андрей Мироненко.

10.04.2017    32211    1СERP    107    

Adaptersoft : Управление Сбором Данных. Получение сводной отчетности в базе 1С из однотипных файлов Excel Промо

Загрузка и выгрузка в Excel Управление холдингом (CPM) Управление холдингом (CPM) v8 УУ Платные (руб)

Управление Сбором Данных — конфигурация на 1С 8.2 для получения сводной отчетности в базе 1С из однотипных файлов Excel. Отлично подходит для организации оперативного или управленческого учета. Сочетает в себе гибкость ms Excel с защищенностью данных в 1С. Простая, понятная и доступная система в отличие от 1С:Консолидации или 1С:Свод отчетов.

15000 руб.

25.09.2014    21419    2    8    

Мотивация персонала в фирмах франчайзи: а она работает?

Управление проектом Бесплатно (free)

Думаем, что практически любого работающего человека интересует вопрос мотивации. Этой проблемой в одинаковой степени озабочены работники и работодатели: как мотивировать людей, сколько платить, как платить, какая часть оплаты должна быть фиксированной, а какая зависеть от результата работы, как это всё повлияет на результаты работы, стоит ли быть строгим и дотошным руководителем или нужно активно делегировать полномочия подчиненным. ВЦ "Раздолье" провело небольшое исследование на тему мотивации и вот его результат. Автор статьи Андрей Мироненко.

03.04.2017    43099    1СERP    231    

Груповая загрузка данных о контрагенте с портала nalog.by по УНП

Обработка справочников WEB v8 УТ10 БП1.6 Беларусь Абонемент ($m)

Предназначена для ГРУППОВОЙ (все аналоги, что видел, работают лишь с одним УНП) загрузки информации с сайта gov.nalog.by Цель обработки - определить контрагентов ликвидированных и находящихся в стадии ликвидации для своевременного отражения в бух.учете расходов, понесенным по долгам по данным контрагентам. (Для справки: Должны уйти на убытки в тот же квартал, когда ликвидировали)

2 стартмани

23.03.2017    9362    3    vova196    1    

Загрузка классификатора банков Беларуси (с сайта - национального банка Беларуси)

Банковские операции Классификаторы Банковские операции v8::БУ v8::УФ БП3.0 Беларусь Абонемент ($m)

Обработка, позволяющая загружать новую информацию напрямую с сайта www.nbrb.by - Национального Банка Беларуси.

1 стартмани

04.03.2017    16705    35    dijee    10    

Главная книга по субсчетам c компактной печатью для 1С 8.2 БП 1.6

Бухгалтерские Оборотно-сальдовая ведомость, Анализ счета Оборотно-сальдовая ведомость, Анализ счета v8 БП1.6 Беларусь БУ Абонемент ($m)

Главная книга для 1С 8.2 БП 1.6. Проверена работа в конфигурации "Бухгалтерия для Беларуси. Редакция 1.6."

1 стартмани

04.03.2017    6418    5    dragonga    0    

Консоль сравнения данных (1С 8, 1С 7.7, SQL, CSV, TXT, DBF, XLS, DOC, XML, JSON, табличный документ) (версия 15.4.56)

Универсальные обработки v8 1cv8.cf Абонемент ($m)

Обработка Консоль сравнения данных (КСД) предназначена для сравнения данных, полученных из разных источников данных: информационных баз 1С 8, 1С 7.7, баз данных SQL, файлов формата CSV/TXT/DBF/XLS/DOC/XML, строки JSON, вручную заполненного табличного документа. Минимально необходимая версия платформы: 8.3.6.1977.

1 стартмани

13.02.2017    34585    127    sertak    100    

Управление пользователями и ролями пользователей

Информационная безопасность v8 1cv8.cf Беларусь Абонемент ($m)

Добрый день. Первая публикация, может, кому понадобится. Возникла идея сделать ее после того, как свернули базу и "порезали" права пользователям. Чтобы в конфигуратор не бегать каждый раз по звонку, сделал из 1С. Критику только приветствую!

1 стартмани

23.01.2017    10100    8    serg-lom89    2