Мониторинг активности пользователя

Администрирование - Журнал регистрации

активность пользователей определение времени простоя

52
Работает ли пользователь с программой? Сколько времени пользователь работает в программе? Что пользователь делает в программе? - эти вопросы стандартно решаются или просмотром журнала регистрации, или с помощью внешних программ. В данной статье будет предложен способ, как следить за активностью пользователей, используя небольшую доработку конфигурации. Бонусом системы мониторинга является автоматическое завершение сеансов пользователей, не работающих с программой длительное время.

В журнале регистрации мы видим только вход/выход из программы и операции по изменению данных. Если пользователь просматривает отчеты, документы, то мы особо ничего не увидим, только вход и выход. Как понять, работает пользователь в программе или нет?

Основная идея

Если абстрагироваться от конкретных функций, выполняемых пользователем, то внешне работа пользователя заключается в открытии окон, перемещении курсора, вводе значений в поля формы. Таким образом, если  список открытых окон в программе не меняется, а активное поле остается тем же самым, то значит пользователь не работает с программой, даже если программа открыта. Другой способ отслеживать активность пользователя описан здесь, он заключается в проверке движений мышью/нажатий клавиатуры.

Получить список окон можно с помощью функции ПолучитьОкна(), доступной на клиенте. Каждое окно содержит список форм. Проверить активность формы можно с помощью функции формы ВводДоступен(). Текущий элемент формы можно получить у свойства формы ТекущийЭлемент.

Регистр сведений "Активность пользователей"

Чтобы понять, изменилось ли что-нибудь за некоторый интервал времени,  нужно хранить предыдущее состояние окон программы. Очевидно, что хранить весь список окон и форм особого смысла нет, поэтому будем по строке, полученной склеиванием заголовков окон и форм, вычислять хеш-функцию, и записывать значение хеша в регистре сведений. 

Тогда структура регистра  АктивностьПользователей будет выглядеть следующим образом:

Измерения:

  • Пользователь (тип "СправочникСсылка.Пользователи")
  • НомерСеанса (тип "Число")

Ресурсы:

  • Хеш (тип "Число")

Реквизиты:

  • Комментарий (тип "Строка")
  • Ссылка (тип "ЛюбаяСсылка")

Периодический (в пределах секунды), режим записи независимый.

Комментарий и ссылка позволяют записать с каким окном и с каким объектом базы данных работал пользователь. Номер сеанса нужен для того, чтобы исключить ситуацию, когда один пользователь запустил два окна программы и "ушел". По номеру сеанса можно их различать и смотреть активность по каждому сеансу.

Как регистрировать активность пользователя?

Чтобы зарегистрировать активность пользователя программы, нужно периодически сканировать список открытых окон и форм в программе. Для этого нужно подключить обработчик ожидания. Это можно сделать из модуля управляемого приложения.

Модификация модуля управляемого приложения  

В процедуре  ПриНачалеРаботыСистемы() модуля управляемого приложения нужно сделать вызов функции из глобального  клиентского модуля. Например, так:

Процедура ПриНачалеРаботыСистемы()
	
	// СтандартныеПодсистемы
	СтандартныеПодсистемыКлиент.ПриНачалеРаботыСистемы();
	// Конец СтандартныеПодсистемы
	
	// ПодключаемоеОборудование
	МенеджерОборудованияКлиент.ПриНачалеРаботыСистемы();
	// Конец ПодключаемоеОборудование
	
	// Постовалов, 01.08.2018
	ВключитьРегистрациюАктивностиПользователя();
	// ---
	
КонецПроцедуры

Общий модуль АктивностьПользователейГлобальный

Функцию ВключитьРегистрациюАктивностиПользователя() создаем в глобальном клиентском общем модуле (это означает, что у общего модуля должны стоять флажки "глобальный" и "клиент").

Процедура ВключитьРегистрациюАктивностиПользователя() Экспорт
	АктивностьПользователейСервер.РегистрацияАктивностиПользователя(0,,"#Начало работы");//1	
	ПодключитьОбработчикОжидания("ПроверитьАктивностьПользователя", 60);//2
КонецПроцедуры

Прокомментируем эту функцию.

// 1. Первой строкой этой процедуры регистрируем начало нового сеанса пользователя с помощью функции РегистрацияАктивностиПользователя() серверного общего модуля АктивностьПользователейСервер. Эта функция будет описана далее. 

//2. Во второй строке подключается обработчик ожидания, который будет вызывать функцию ПроверитьАктивностьПользователя() каждую минуту. Эта функция располагается в этом же модуле и выглядит следующим образом:

Процедура ПроверитьАктивностьПользователя() Экспорт
Окна = ПолучитьОкна();
ТекстСообщения = "";
Ссылка = Неопределено;
АктивнаяФорма = "";
Для Каждого Окно Из Окна Цикл
	ТекстСообщения = ТекстСообщения + "["+Окно.Заголовок+"] ";
	Формы = Окно.Содержимое;
	Для Каждого Ф Из Формы Цикл
		Если Ф.ВводДоступен() Тогда
			// Это активная форма
			Ссылка = ПолучитьЗначениеСвойства(ПолучитьЗначениеСвойства(Ф,"Объект"),"Ссылка");//3
			Активность="!";
			АктивнаяФорма = Ф.Заголовок;
		Иначе
			Активность="";
		КонецЕсли;	
		ТекстСообщения = ТекстСообщения 
		+ "("+Ф.Заголовок+": "+ПолучитьЗначениеСвойства(Ф.ТекущийЭлемент,"Имя")+Активность+")";
		КонецЦикла;
КонецЦикла;
ЗавершитьСеанс = АктивностьПользователейСервер.РегистрацияАктивностиПользователя(
Хэш(ТекстСообщения),Ссылка,АктивнаяФорма); //4
Если ЗавершитьСеанс Тогда // 5
	ЗавершитьРаботуСистемы(Истина);
КонецЕсли;
КонецПроцедуры

// 3. Чтобы понять, с каким объектом работает пользователь, хотелось бы получить ссылку на объект. Как правило (но, к сожалению, не обязательно), главный реквизит формы справочника или документа называется "Объект". Так как мы не знаем точно, является ли форма формой документа или справочника, то получение значения этого реквизита сделаем через вспомогательную функцию ПолучитьЗначениеСвойства(). С другой стороны, может оказаться, что форма имеет главный реквизит с названием "Объект", но у него нет реквизита Ссылка.

Функция ПолучитьЗначениеСвойства(Переменная, Свойство)
	Если Переменная<>Неопределено 
		И ТипЗнч(Переменная)<>Тип("Null")
		И ТипЗнч(Переменная)<>Тип("Строка")
		И ТипЗнч(Переменная)<>Тип("Число")
		И ТипЗнч(Переменная)<>Тип("Дата")
		И ТипЗнч(Переменная)<>Тип("Булево")
		И ТипЗнч(Переменная)<>Тип("ДекорацияФормы")
		Тогда
		Стр = Новый Структура(Свойство, Неопределено);
		ЗаполнитьЗначенияСвойств(Стр, Переменная);
		Возврат Стр[Свойство];
	КонецЕсли;
	Возврат Неопределено;
КонецФункции

// 4. Хэш-функцию от строки вычисляем по следующему алгоритму:

//////////////////////////////////////////////////////////////////////
 //СтрокаХэш - исходный текст
 //hash- начальное значение hash
 // М - множитель (влияет накачество хэш и производительность)
 // TABLE_SIZE - размер получаемого ключа, как Максимальная величина + 1
Функция Хэш(СтрокаХэш, hash=0, M = 31, TABLE_SIZE = 18446744073709551616)
    //TABLE_SIZE = 18446744073709551615; 64 бита
    //M = 31; Умножитель
    ДлинаСтроки = СтрДлина(СтрокаХэш);
    Для к=1 по ДлинаСтроки цикл
        hash = M * hash + КодСимвола(Сред(СтрокаХэш,к,1));
    конеццикла;
    возврат hash%TABLE_SIZE;
КонецФункции

//5. Если функция  РегистрацияАктивностиПользователя()  вернула Истина, то завершаем сеанс работы пользователя.

Общий модуль АктивностьПользователейСервер

Теперь перейдем к записи в регистр. Функция РегистрацияАктивностиПользователя располагается в серверном общем модуле АктивностьПользователейСервер.

Функция РегистрацияАктивностиПользователя(Хеш,Ссылка=Неопределено,Комментарий = "") Экспорт
	ТекДата = ТекущаяДата();
	НомерСеанса = НомерСеансаИнформационнойБазы();
	ЗавершитьСеанс = Ложь;

	Запрос = Новый Запрос;
	Запрос.Текст = 
		"ВЫБРАТЬ
		|	АктивностьПользователейСрезПоследних.Период,
		|	АктивностьПользователейСрезПоследних.Пользователь,
		|	АктивностьПользователейСрезПоследних.Хеш,
		|	АктивностьПользователейСрезПоследних.Комментарий,
		|	АктивностьПользователейСрезПоследних.Ссылка
		|ИЗ
		|	РегистрСведений.АктивностьПользователей.СрезПоследних(
		|			&ТекДата,
		|			Пользователь = &ТекущийПользователь
		|				И НомерСеанса = &НомерСеанса) КАК АктивностьПользователейСрезПоследних";
	
	Запрос.УстановитьПараметр("ТекДата", ТекДата);
	Запрос.УстановитьПараметр("ТекущийПользователь", ПараметрыСеанса.ТекущийПользователь);
	Запрос.УстановитьПараметр("НомерСеанса",НомерСеанса);
	РезультатЗапроса = Запрос.Выполнить();
	Выборка = РезультатЗапроса.Выбрать();
	
	Если Выборка.Следующий() Тогда
		Простой = 0;
		Если НачалоДня(ТекДата)=НачалоДня(Выборка.Период) Тогда
			Простой = ТекДата-Выборка.Период; // в секундах	
		КонецЕсли;
		
		// Проверяем простой
		Если Простой > 3600	Тогда
			ЗавершитьСеанс=Истина;
		КонецЕсли;
		
		Если Выборка.Хеш = Хеш Тогда
			// Активности не было...
			Возврат ЗавершитьСеанс;
		КонецЕсли;
	КонецЕсли;
	
	Рег = РегистрыСведений.ДОРН_АктивностьПользователей.СоздатьМенеджерЗаписи();
	Рег.Период = ТекДата;
	Рег.Пользователь = ПараметрыСеанса.ТекущийПользователь;
	Рег.НомерСеанса = НомерСеанса;
	Рег.Хеш = Хеш;
	Рег.Комментарий = Комментарий;
	Рег.Ссылка=Ссылка;
	Рег.Записать(Истина);
	
	Возврат ЗавершитьСеанс;
КонецФункции	

В функции сначала с помощью запроса получаем текущее состояние активности пользователя. Если хеш не изменился, то вычисляем время простоя. Если время простоя превышает максимально возможное (в примере задано 3600 секунд), то выполняется завершение работы системы. Если значение хеш-функции изменилось, тогда записываем в регистр сведений новое значение хеша.

Насколько мониторинг замедляет работу пользователя?

По проведенным замерам времени проверка активности занимает менее 1 секунды, поэтому визуально для пользователя существенного замедления работы не происходит. 

Результаты

Активность пользователей можно анализировать или непосредственно, просматривая записи регистра (рис.1), или написать специальные отчеты. Например, я немного модифицировал стандартную обработку "Активные пользователи" (рис. 2), добавив туда колонку "Статус" и написал отчет "Распределение работы пользователей"  (рис. 3). 

Регистр сведенийРис. 1.

Активные пользователиРис. 2.

Рис. 3.

52

См. также

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. Darklight 16 11.10.18 16:24 Сейчас в теме
Хорошее решение. Я как раз сейчас делаю аналогичное (!) по завершению сеансов, тоже включающее отслеживание окон (но у меня гораздо больше функционала заложено, поэтому пока не выкладываю, хотя об отслеживании окон уже писал тут недавно в комментариях к другой публикации тоже на тему закрытия неактивных сеансов).

У Вас подсмотрел идею о хешировании строки открытых форм (хотя уже, в общем-то, тоже об этом думал) - не знаю пока - будут ли использовать - у меня иное хранение текущего состояния, думал просто хранить идентификаторы форм списком, т.к. я делаю расширение конфигурации в режиме совместимости для платформы 1С 8.3.9 - а там ещё пока нельзя в расширение изменять структуру данных БД.

Не пойму только, почему Вы применили свою функцию хеширования, а не взяли типовой объект из 8.3 "ХешированиеДанных"?

Ну и жаль, что Вы не привели в описании алгоритм завершения работы системы - там тоже есть свои нюансы.
3. postovalov 166 12.10.18 04:32 Сейчас в теме
(1)
Не пойму только, почему Вы применили свою функцию хеширования, а не взяли типовой объект из 8.3 "ХешированиеДанных"?


Функцию хеширования я взял отсюда: https://infostart.ru/public/70030/. Встроенную функцию не проверял, но думаю, что тоже можно использовать, но заранее не могу сказать, какой вариант будет быстрее, т.к. алгоритмы хеширования разные.
2. shurik_shurik 11.10.18 17:08 Сейчас в теме
Идея интересная, но вопрос, зачем делать обращение к срезПоследних регистра, если у Вас и так есть
"создаем в глобальном клиентском общем модуле (это означает, что у общего модуля должны стоять флажки "глобальный" и "клиент")"

Не проще хранить последние данные в глобальных переменных объявленных в этом модуле ? и не дергать каждый раз базу "по пустякам" ?
4. postovalov 166 12.10.18 04:35 Сейчас в теме
(2) Глобальных переменных в управляемом приложении нет, но использование параметра сеанса должно ускорить работу программы.
5. Darklight 16 12.10.18 09:13 Сейчас в теме
(4)Вот поэтому я храню по-другому, т.к. в расширениях и параметров сеансов нет, которые, всё-равно, доступные только в серверном контексте :-( поэтому, приходится извращаться.
9. azhilichev 12.10.18 16:18 Сейчас в теме
(4)
Глобальных переменных в управляемом приложении нет, но использование параметра сеанса должно ускорить работу программы.


Глобальные клиентские переменные можно задавать в модуле управляемого приложения.
postovalov; +1 Ответить
13. postovalov 166 17.10.18 14:18 Сейчас в теме
(9) Попробовал так сделать. Переменная в модуле управляемого приложения действительно сохраняет значение, но пришлось процедуру-обработчик ожидания также перенести также в этот модуль.
6. Иваныч 22 12.10.18 10:12 Сейчас в теме
Нравится, но пока на 7.7 пользуюсь другим. А вам ставлю плюс
7. astracrypt 41 12.10.18 11:12 Сейчас в теме
У нас используют приложение для Windows. Которое измеряет расстояние курсора в метрах пройденное по экрану. Те у кого больше 20 км за месяц тому премию дают.
8. azhilichev 12.10.18 16:13 Сейчас в теме
Если Переменная<>Неопределено 
		И ТипЗнч(Переменная)<>Тип("Null")
		И ТипЗнч(Переменная)<>Тип("Строка")
		И ТипЗнч(Переменная)<>Тип("Число")
		И ТипЗнч(Переменная)<>Тип("Дата")
		И ТипЗнч(Переменная)<>Тип("Булево")
		И ТипЗнч(Переменная)<>Тип("ДекорацияФормы")
		Тогда


Зачем вы заставляете систему делать лишние действия? Так ведь лучше, правда?

ТипЗначения = ТипЗнч(Переменная)
Если Переменная <> Неопределено
   И ТипЗначения <> Тип("NULL") И ТипЗначения <> Тип("Строка")
   И ТипЗначения <> Тип("Число") И ТипЗначения <> Тип("Дата")
   И ТипЗначения <> Тип("Булево") И ТипЗначения <> Тип("ДекорацияФормы") Тогда


Чтобы гарантированно выкинуть пользователя, лучше использовать не ЗавершитьРаботуСистемы(), а ПрекратитьРаботуСистемы(). Если у вас есть модальный диалог, ЗавершитьРаботуСистемы() не отработает.
10. cssprite 25 13.10.18 15:26 Сейчас в теме
(8)
Зачем вы заставляете систему делать лишние действия? Так ведь лучше, правда?
:))

ТипЗначения = ТипЗнч(Переменная);
ЧтотоСделать = НЕ (Переменная = Неопределено
   ИЛИ ТипЗначения = Тип("NULL") ИЛИ ТипЗначения = Тип("Строка")
   ИЛИ ТипЗначения = Тип("Число") ИЛИ ТипЗначения = Тип("Дата")
   ИЛИ ТипЗначения = Тип("Булево") ИЛИ ТипЗначения = Тип("ДекорацияФормы"));
Если ЧтотоСделать  Тогда ...
12. postovalov 166 15.10.18 01:21 Сейчас в теме
(10) не уверен, что так оптимальнее, чем в (8). Насколько я помню, логическое "И" вычисляется до первого ложного значения. А вот для логического "ИЛИ" нужно вычислить все условия.
16. cssprite 25 18.10.18 22:48 Сейчас в теме
(12)
А вот для логического "ИЛИ" нужно вычислить все условия
Зачем, если первое ИСТИНА даст всему выражению ИЛИ - ИСТИНА ?
Про оптимальность прямо не скажешь, зависит от того, какие значения чаще принимает Переменная, просто для выполнения данного условия с использованием И НЕ РАВНО И НЕ РАВНО ... надо проверить все условия И, а для РАВНО ИЛИ РАВНО ... до первой ИСТИНЫ ...

Вообще извиняюсь, прямо к теме отношения не имеет, тут больше субъективное отношение - длинное И НЕ РАВНО И НЕ РАВНО ... режет глаз ))
17. postovalov 166 19.10.18 10:23 Сейчас в теме
(16) Да, вы правы, с точки зрения количества сравнений их будет ровно столько же. Единственное, что вы добавляете еще одну логическую операцию (НЕ) и вспомогательную переменную.

Вообще извиняюсь, прямо к теме отношения не имеет, тут больше субъективное отношение - длинное И НЕ РАВНО И НЕ РАВНО ... режет глаз ))


Мне, наоборот, удобнее, когда условия находятся на разных строках. Так и нагляднее, и добавлять проще. В общем на "вкус и цвет товарищей нет".
11. postovalov 166 15.10.18 01:17 Сейчас в теме
(8) Спасибо за замечание, конечно, нужно поправить. Что касается, ЗавершитьРаботуСистемы() или ПрекратитьРаботуСистемы(), то выбор зависит от того, какая поставлена цель. Если надо убрать сеансы, в которых пользователи открыли программу и не работают, то достаточно ЗавершитьРаботуСистемы(). Если же цель завершить сеанс, даже если имеется открытый (не сохраненный) документ, то да тогда нужно использовать ПрекратитьРаботуСистемы().
14. Vyatcheslav 10 17.10.18 14:29 Сейчас в теме
Интересный подход. Но концептуально странный и даже опасный, если пользователи поймут что к чему. Ведь важно не то, сколько сотрудник ДЕЛАЛ, а то, сколько он СДЕЛАЛ. Почувствуйте разницу. Неопытный сотрудник может очень бурно изображать деятельность, но выхлопа от этого будет мало. Это относится к любой работе и профессии.

Когда я был неопытным специалистом 1С и только начинал, были задачи по УПП, ради решения которых я упорно сидел по несколько дней в конфигураторе в режиме отладки, пытаясь понять поведение системы, хотя задача в теории решалась за 5 минут грамотным консультантом и без захода в конфигуратор.

У нас есть отчет по пользователям в базах 1С, который показывает, кто сколько документов в базе создал за период, сгруппированные по типам документов и с указанием количества строк в ТЧ документов. Дает представление о объеме выполненной работы. Конечно, сильно зависит от должностных обязанностей работников, слепо количественно позволяет только оценивать тех, кто чисто на первичке сидит. У кого обязанности налоговый учет, декларации, закрытие месяца, всякая другая отчетность и т.д., понятно, так не оценить, документов они вводят не много.

Мне симпатичен способ нормирования, когда на одного расчетчика 200 сотрудников + зуп отчетность, например, или на одного буха 2000-4000 основных средств и т.д., но вообще тема очень сложная, пользователь может реально зашиваться и не успевать только потому, что многие функции не автоматизированы и он не знает, что это можно автоматизировать, или функции автоматизированы, но пользователь не знает, как можно работать эффективнее и никто его не учит. Тут только может помочь желание непосредственного руководителя сделать работу пользователя эффективнее + привлечение консультантов-программистов 1С, аудит рабочих и производственных процессов.

ВЫВОД: Универсального счетчика быть не может в принципе, по которому можно объективно оценить любого пользователя, везде необходимо подходить с умом. Там, где сотр решает бизнес-цели, там проще, можно оценивать просто по принесенной выручке/прибыли/выработке и т.д. Там, где обслуживающие подразделения: бухи, юристы, финансисты-экономисты, айтишники и т.д. все намного сложнее.
15. postovalov 166 18.10.18 06:43 Сейчас в теме
(14) В статье описан метод регистрации активности пользователя, но каждый может использовать его для своих целей. Если премию выписывать, то да, это опасный подход, согласен.

Мне симпатичен способ нормирования, когда на одного расчетчика 200 сотрудников + зуп отчетность, например, или на одного буха 2000-4000 основных средств и т.д., но вообще тема очень сложная, пользователь может реально зашиваться и не успевать только потому, что многие функции не автоматизированы и он не знает, что это можно автоматизировать, или функции автоматизированы, но пользователь не знает, как можно работать эффективнее и никто его не учит. Тут только может помочь желание непосредственного руководителя сделать работу пользователя эффективнее + привлечение консультантов-программистов 1С, аудит рабочих и производственных процессов.


Как раз здесь интересно отношение "Объем выполненной работы (количество введенных документов, справочников, строк табличной части и т.п.)" к продолжительности активной работы пользователя. Если у одного пользователя этот показатель будет существенно выше, а у другого существенно ниже, то это предмет для анализа, что пользователь делает неэффективно, почему тратит больше времени на выполнение одних и тех же действий.
18. Si-ned 4 19.10.18 14:09 Сейчас в теме
Повторил весь код для УПП 1.3 для обычного приложения (код вставлял в ПриНачалеРаботыСистемы() обычного приложения). После запуска окно программы запускается, виден интерфейс, но окно заставки не исчезает и висит. Через диспетчер программу не закроешь, так как все диалоги скрываются за окном заставки 1С. Для обычного приложения не работает эта схема что-ли?
19. postovalov 166 19.10.18 16:39 Сейчас в теме
(18) Весь код разработан для управляемого приложения. На обычном не проверял. Думаю, что надо пройти по всем модулям в режиме отладчика.
20. nano1c 135 24.10.18 09:17 Сейчас в теме
(19) ПолучитьОкна() - в обычном не работает. Я делал свою функцию получающую открытые окна в обычном приложении, но через внешнюю компоненту. Вообще у меня давно сделан полный контроль отработанного времени с автоматической рассылкой т13 и т.п. (см. публикацию), но по данным с карт, на другой организации подключил это решение к данным открытий окон - тоже нормально. Сейчас делаю автоматический анализ всех действий - чтобы понять типовые бизнес-маршруты и нетиповые действия анализировать - собирался публикацию писать, но все времени не найду..
postovalov; +1 Ответить
21. xan333 29 05.12.18 10:54 Сейчас в теме
Сделал Расширение для типовых конфигураций 1С на управляемых формах в режиме совместимости 8.3.12. основанное на данной статье https://infostart.ru/public/931108/
Оставьте свое сообщение